Page MenuHomePhabricator

[BUG] Investigate Drop in User Count and Activity for Image Tags
Closed, ResolvedPublicBUG REPORT

Description

@JKatzWMF noticed a drastic drop in unique users and image tag events as of ~2020-07-02 from ~50 to >5 users. I'm checking other user activity but this jumps out as most problematic, will update if other drops show up. Query for session and source counts across all editor activity looks normal.

See comparison All Users vs Image Tag Users here
Incidentally when querying for all data more single 'future' events are showing up 2020-07-21, 2020-07-22 -2020-08-15, most likely the same user with faulty date on device(?)

Steps to reproduce

Queries for data:
Image tags

SELECT
    DATE(SUBSTRING(event.client_dt,1,10)) as date,
    count(distinct event.app_install_id) as users,
    count(distinct event.session_token) as tokens,
    count(event.session_token) as tags
from event.mobilewikiappedit 
where 
event.source = '#suggestededit-imgtag-custom 1.0' AND 
YEAR = 2020 AND MONTH >= 5 AND day >= 1
group by DATE(SUBSTRING(event.client_dt,1,10))

All Users

SELECT
    DATE(SUBSTRING(event.client_dt,1,10)) as date,
    count(distinct event.app_install_id) as users,
    count(distinct event.session_token) as tokens,
    count(event.session_token) as sessions
from event.mobilewikiappedit 
where 
YEAR = 2020 AND MONTH >= 5 AND day >= 1
group by DATE(SUBSTRING(event.client_dt,1,10))

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 15 2020, 9:41 PM

Change 613244 had a related patch set uploaded (by Dbrant; owner: Dbrant):
[mediawiki/extensions/WikimediaEditorTasks@master] Update logic for recording Image Tag edits.

https://gerrit.wikimedia.org/r/613244

Change 613244 merged by jenkins-bot:
[mediawiki/extensions/WikimediaEditorTasks@master] Update logic for recording Image Tag edits.

https://gerrit.wikimedia.org/r/613244

@SNowick_WMF - This should have been fixed last release. Can you run numbers again?

@Dbrant @Charlotte I am not seeing counts back to expected values, not seeing event.source:#suggestededit-imgtag-custom 1.0 as result when querying using latest app version.

SELECT 
DISTINCT(event.source) 
FROM 
mobilewikiappedit 
WHERE regexp_like(useragent.wmf_app_version, '2.7.50330-r-2020-08-04')

Charts in Image Tag Dashboard have been updated with latest counts.

SNowick_WMF assigned this task to Dbrant.Sep 1 2020, 5:06 PM

This is resolved, data is on Dashboard Android Image Tags

Data accessed by querying revision table with INSTR(comment_text, 'add-depicts') or mwf.mediawiki_history with RLIKE(event_comment, 'add-depicts')

@SNowick_WMF - I see a chart now on the dashboard, but the data makes no sense to me. What is a "bot" in this context? All image tags added through the SE feature are manually entered. Explanation and analysis is needed here, because the data is not self-explanatory.

@SNowick_WMF
I'm not sure what the self_created parameter is in that table, but it doesn't appear to be relevant. It's possible that mediawiki is treating those edits as "bot" edits because they are made through the API, but that doesn't matter; we're just interested in the total number of those edits. (Your filtering based on the presence of add-depicts is correct, and I believe that's all it needs to be)

The numbers in the chart look reasonable, and probably don't need to be broken down by "bot" vs. "self-created".

@Charlotte @Dbrant Changed chart to show total count rather than split by user type (which may not be accurate anyway and not relevant for this task.)

Dbrant closed this task as Resolved.Oct 2 2020, 6:01 PM