Page MenuHomePhabricator

Cursor jumps when pressing shift
Open, Needs TriagePublic

Description

This task is about an issue where the cursor can jump/change positions when is pressed when typing in the new wikitext editor, the visual editor or the Reply tool's visual mode.

Behavior

The below described the experience @ppelberg had when using the new wikitext editor. @AdHuikeshoven reports having a similar issue when using the Reply tool's visual mode.

  1. Ensure the New wikitext mode is enabled in Beta Features
  2. Open the New wikitext editor on any page (I experienced the issue below while editing this page: https://en.wikipedia.org/wiki/Talk:Metaphors_We_Live_By )
  3. Type a sentence (I don't think it matters what that sentence contains)
  4. Press the SHIFT key

Actual

  1. ❗️Notice your cursor jumps to the beginning of the line you wrote in Step 3.: https://youtu.be/qkbsoVvqzTQ

Expected

  1. ✅ Nothing happens; your cursor remains in its current position

Environment

  • Editing interface: New wikitext mode
  • Browser: Chrome 83.0.4103.116
  • Browser extensions: see below

Done

  • The "Expected" behavior is implemented

Extensions

Screen Shot 2020-07-16 at 6.54.47 PM.png (1×2 px, 475 KB)

Event Timeline

I can't reproduce this. In your video there appears to be some plugin shown when you select text in the link, that could be related. Have you tried to reproduce this with a clean account with no gadgets or browser plugins enabled?

ppelberg moved this task from Backlog to Triaged on the DiscussionTools board.
ppelberg moved this task from Next Quarter to Freezer on the Editing-team board.

I had this behavior in new wikitext editor this week. Turning off new wikitext editor helped, and switching to source mode editing helped.