Page MenuHomePhabricator

Integrate Stretch 9.13 point update
Open, MediumPublic

Description

The stretch 9.13 point release brings a number of bugfixes (including some security fixes):
https://lists.debian.org/debian-announce/2020/msg00004.html

Use this ticket to track the respective updates across the cluster. I've verified that all removed packages are not in use in our infrastructure.

  • bacula
  • base-files
  • batik
  • ca-certificates
  • clamav
  • cups
  • dbus
  • erlang
  • exiv2
  • glib-networking
  • gnutls28
  • intel-microcode
  • jackson-databind
  • libbusiness-hours-perl
  • libdbi
  • libexif
  • linux
  • linux-latest
  • mariadb-10.1
  • nfs-utils
  • nginx
  • perl
  • rails
  • rake
  • ruby-json
  • ruby2.3
  • tzdata
  • websockify
  • xdg-utils

These are unused by us:

  • acmetool
  • atril
  • c-icap-modules
  • chasquid
  • checkstyle
  • compactheader
  • cram
  • csync2
  • debian-security-support
  • fex
  • file-roller
  • fwupd
  • gosa
  • heartbleeder
  • iptables-persistent
  • libclamunrar
  • libembperl-perl
  • libvncserver
  • megatools
  • mod-gnutls
  • mongo-tools
  • neon27
  • node-url-parse
  • nvidia-graphics-drivers
  • pcl
  • php-horde
  • php-horde-data
  • php-horde-form
  • php-horde-gollem
  • php-horde-trean
  • phpmyadmin
  • postfix
  • proftpd-dfsg
  • python-icalendar
  • roundcube
  • sendmail
  • sogo-connector
  • ssvnc
  • storebackup
  • swt-gtk
  • tinyproxy
  • wpa
  • xml-security-c
  • xtrlock

These are only used by the installer, which was rebuilt locally:

  • debian-installer
  • debian-installer-netboot-images

Event Timeline

Mentioned in SAL (#wikimedia-operations) [2020-07-22T15:31:09Z] <moritzm> updated stretch installer image to Stretch 9.13 release T258407