Page MenuHomePhabricator

SystemGifts Back to Profile Link Does Not Work
Closed, ResolvedPublic

Description

The link to go back to a user's profile on their system gift page doesn't work. It just shows this: [[User:Username|< Back to Username's profile]] without the wikitext link working.

It works for regular awards though.

Event Timeline

Vishkujo created this task.Jul 21 2020, 8:15 PM
Restricted Application added a project: Social-Tools. · View Herald TranscriptJul 21 2020, 8:15 PM

Change 615299 had a related patch set uploaded (by Jack Phoenix; owner: Jack Phoenix):
[mediawiki/extensions/SocialProfile@master] Use full wikitext parsing for the "ga-back" i18n msg so that the link works as intended

https://gerrit.wikimedia.org/r/615299

Change 615299 merged by Jack Phoenix:
[mediawiki/extensions/SocialProfile@master] Use full wikitext parsing for the "ga-back" i18n msg so that the link works as intended

https://gerrit.wikimedia.org/r/615299

I was still having the issue after that patch, but I found that it's fixed if you also change

$this->msg( 'ga-back-link', $gift['user_name'] )->escaped() .

in SpecialViewSystemGift.php to this:

$this->msg( 'ga-back-link', $gift['user_name'] )->parse() .

Change 615424 had a related patch set uploaded (by Jack Phoenix; owner: Jack Phoenix):
[mediawiki/extensions/SocialProfile@master] One more escaping fix for the "back to user's profile" link

https://gerrit.wikimedia.org/r/615424

ashley closed this task as Resolved.Jul 22 2020, 11:01 AM
ashley claimed this task.
ashley removed a project: Patch-For-Review.
ashley added a subscriber: ashley.

I was still having the issue after that patch, but I found that it's fixed if you also change

$this->msg( 'ga-back-link', $gift['user_name'] )->escaped() .

in SpecialViewSystemGift.php to this:

$this->msg( 'ga-back-link', $gift['user_name'] )->parse() .

Good catch, thanks! I've fixed that in the new patch. :)

Seems that the original "escaping cleanup" patch from March (rESPR8f447f1334328e4df8e411e4e45bd2902eb13bbc) broke the "back to user profile" links in both SystemGifts-related special pages (ViewSystemGift and ViewSystemGifts); these should now be fixed. Thanks for reporting the issue! As always, please report any and all issues you may encounter so we can get them fixed.

Change 615424 merged by jenkins-bot:
[mediawiki/extensions/SocialProfile@master] One more escaping fix for the "back to user's profile" link

https://gerrit.wikimedia.org/r/615424