Page MenuHomePhabricator

Desktop improvements only default for logged out users
Open, MediumPublic

Description

Steps to reproduce

  1. Go to euwiki (make sure your user preference was not set to legacy vector off prior to July 22)
  2. Log in

Expected:

  • Desktop improvements should be default

Observed:

  • Legacy vector is default

Reproduction on frwiki

legacy vector setting not touched
Other preference set (date preference)
New vector enabled by default
Expected: new version
Observed: old version

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptWed, Jul 22, 12:16 PM
ovasileva triaged this task as High priority.Wed, Jul 22, 12:17 PM

It's the same in incognito mode, so it seems it's not on the browsers' side.

Jdlrobson added a subscriber: Jdlrobson.EditedFri, Jul 24, 6:56 PM

@ovasileva I cannot replicate this. I used a test account I haven't used in over a year and after logging in I get the new Vector. The code also supports this.

My guess is one of the accounts you've been testing on changed another preference. Note any change to any preference will have cached the previous value of legacy. Note changing a preference doesn't necessarily mean a visit to Special:Preferences, for instanceif you used the sidebar even during the testing phase with that account, you would have triggered an update to preferences and marked yourself in the legacy group.

Here's what I saw post login with that account:

Suggested: close as invalid

Jdlrobson raised the priority of this task from High to Needs Triage.Fri, Jul 24, 6:57 PM
ovasileva triaged this task as Medium priority.Thu, Jul 30, 10:17 AM
ovasileva added a subscriber: phuedx.

Discussed this with @phuedx and will keep open for some additional analysis into what we can potentially do here

Jdlrobson closed this task as Declined.Tue, Aug 4, 12:32 AM

@ovasileva can you elaborate on your chat with Sam? Did we learn something new? What analysis is expected here?

phuedx added a comment.Tue, Aug 4, 5:23 PM

@ovasileva: Can you confirm that this is still happening on the account that you were using?

@Jdlrobson: I wondered out loud to Olga if this was related to T258971: PrefUpdate event.isDefault field is not recoded correctly for some user properties. Having now looked into that task, I don't believe that's the case.

Jdlrobson reopened this task as Open.Tue, Aug 4, 5:35 PM

Sorry I didn't mean to decline this (sorry if that looked passive agressive!) - although I do think it should be :)

@phuedx I was unable to verify on some super old accounts, so I hypothesised that what had happened is preferences had been saved resulting in the default value being set. I suggested that even clicking the sidebar button would trigger a preference save via the API which in theory should also set undefined values like this one.

@phuedx, @Jdlrobson - difficult to confirm on wikis that have already been switched, but can confirm on frwiki later today.

ovasileva updated the task description. (Show Details)Thu, Aug 6, 2:26 PM
phuedx added a comment.EditedFri, Aug 7, 12:47 PM

I can't reproduce this. Here's what I've tried:

In production

  1. I logged into officewiki with my Phuedx (WMF) account, which was created before 22nd July 2020
  2. I observed that I saw the new Vector treatment
  3. I navigated to Special:Preferences
  4. I ran the following in my browser's console
mw.user.options.values.VectorSkinVersion // => undefined
  1. I updated my date format preference
  2. I clicked "Save"
  3. I observed that I still saw the new Vector treatment
  4. I ran the following in my browser's console
mw.user.options.values.VectorSkinVersion // => '2'

In development

  1. I created a new development wiki with MediaWiki-Docker
  2. I observed that I saw the old Vector treatment
  3. I created a new user, Phuedx
  4. I deleted any user preferences in the user_properties table
  5. I added the following to LocalSettings.php
LocalSettings.php
$wgVectorDefaultSkinVersion = $wgVectorDefaultSkinVersionForExistingAccounts = $wgVectorDefaultSkinVersionForNewAccounts = '2';
  1. I observed that I saw the new Vector treatment
  2. I navigated to Special:Preferences
  3. I ran the following in my browser's console
mw.user.options.values.VectorSkinVersion // => undefined
  1. I updated my date format preference
  2. I clicked "Save"
  3. I observed that I still saw the new Vector treatment
  4. I ran the following in my browser console
mw.user.options.values.VectorSkinVersion // => '2'

Further to the above, you can reproduce the initial conditions for this bug report on any of the desktop-improvements wikis by running the following in your console:

new mw.Api().saveOption( 'VectorSkinVersion', null );

@ovasileva: If there's anything missing from my investigation above, I'd be happy to add it. However, I can't reproduce this in a production or in a development environment. My recommendation would be to resolve this task as Declined.