Page MenuHomePhabricator

[Regression pre-wmf.2] Map dialog in VE hangs and VE does not open on page reload
Open, Needs TriagePublic

Description

This started happening within the last one hour. Before that, I was able to complete a full regression cycle on VE, then I noticed an option "Mention a user" under Insert menu. Clicking on which was doing nothing but there was an error in the console. Then it disappeared the next minute and after that I am not being able to open VE at all.

Behavior

  1. Visit https://en.wikipedia.beta.wmflabs.org/wiki/User:RYasmeen_(WMF)/sandbox?veaction=edit
  2. Click Insert > Map

Actual

  1. ❗️ Map dialog hangs in loading state indefinitely
  2. Reload the page
  3. Click Edit
  4. ❗️ VE fails to open

Expected

  1. ✅ Map dialog opens
  2. ✅ Click Insert
  3. ✅ Maps shown in document
  4. ✅ Publish changes etc.

Done

  • "Expected" behavior is implemented

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 28 2020, 12:59 AM

I noticed an option "Mention a user" under Insert menu. Clicking on which was doing nothing but there was an error in the console.

I can reproduce this. It only happens on pages that load the reply tool (so talk pages, or when using dtenable=1).

Also, and this is probably related, it looks like the option to insert "Your signature" always appears regardless of the namespace.

Then it disappeared the next minute and after that I am not being able to open VE at all.

It seems to be loading for me. Maybe there's some combination of opening and closing both VE and reply widget in the right order that causes this, but I didn't find a way to reproduce.

JTannerWMF moved this task from To Triage to Triaged on the VisualEditor board.
JTannerWMF added a subscriber: JTannerWMF.

@ppelberg is going to split this into two tasks and this may need @Ryasmeen to reproduce the issue

DLynch added a subscriber: DLynch.Jul 28 2020, 4:08 PM

I can reproduce this. It only happens on pages that load the reply tool (so talk pages, or when using dtenable=1).

Shouldn't this essentially mean "only happens on pages where we already try to disable VE"?

I noticed an option "Mention a user" under Insert menu. Clicking on which was doing nothing but there was an error in the console.

I can reproduce this. It only happens on pages that load the reply tool (so talk pages, or when using dtenable=1).

Also, and this is probably related, it looks like the option to insert "Your signature" always appears regardless of the namespace.

@ppelberg is going to split this into two tasks and this may need @Ryasmeen to reproduce the issue

This part is now filed as T259039, let's continue there.

Ryasmeen added a comment.EditedJul 28 2020, 10:25 PM

I am not sure if these two issues are related. But this issue is still happening for me. But I have some more details now:

  1. This is happening on Chrome on Mac. Tried it on Safari, cannot reproduce it there. Also not on Windows.
  2. This seems to be get fixed when I do hard refresh on the page but then comes back again when I switch to the discussion page. The steps are as follows:

At this point, the URL changes to https://en.wikipedia.beta.wmflabs.org/wiki/User:RYasmeen_(WMF)/sandbox?veaction=edit, but VE does not open.

Ryasmeen renamed this task from [Regression pre-wmf.2] VE is not opening on Beta cluster to [Regression pre-wmf.2] VE is not opening on Beta cluster using Chrome.Jul 28 2020, 11:05 PM
Ryasmeen added a comment.EditedJul 28 2020, 11:15 PM

I am wondering if this is part of a bigger problem on Beta cluster. I am also being unable to switch tabs on Preferences page on Beta cluster at this point. There is an eternal loading bar animation appearing for the field "Prohibit these users from emailing me:" on my User profile page. Again this is happening only when I am using Chrome.

ppelberg added a comment.EditedJul 28 2020, 11:29 PM
  1. This is happening on Chrome on Mac. Tried it on Safari, cannot reproduce it there. Also not on Windows.
  2. This seems to be get fixed when I do hard refresh on the page but then comes back again when I switch to the discussion page. The steps are as follows:

At this point, the URL changes to https://en.wikipedia.beta.wmflabs.org/wiki/User:RYasmeen_(WMF)/sandbox?veaction=edit, but VE does not open.

Hmm, I'm having a hard time reproducing the above.

When I follow the steps above I am able to open VE [I think]: https://youtu.be/NsKfX76pZbU

Environment:

  • Chrome 84.0.4147.89
  • macOS 10.15.4
  1. This is happening on Chrome on Mac. Tried it on Safari, cannot reproduce it there. Also not on Windows.
  2. This seems to be get fixed when I do hard refresh on the page but then comes back again when I switch to the discussion page. The steps are as follows:

At this point, the URL changes to https://en.wikipedia.beta.wmflabs.org/wiki/User:RYasmeen_(WMF)/sandbox?veaction=edit, but VE does not open.

Hmm, I'm having a hard time reproducing the above.

When I follow the steps above I am able to open VE [I think]: https://youtu.be/NsKfX76pZbU

Environment:

  • Chrome 84.0.4147.89
  • macOS 10.15.4

This could be related with the special scenario of T259039 which happened when I enabled the tab for adding a new section. Maybe try that first on your sandbox? I will re-test this on my end once that's fixed anyways.

Hey @Ryasmeen , the engineers are unable to reproduce this, can you show @ppelberg what you're seeing during your 1:1.

Hey @Ryasmeen , the engineers are unable to reproduce this, can you show @ppelberg what you're seeing during your 1:1.

Nope. Because this is now fixed :) Was probably related with T259039.

ppelberg closed this task as Resolved.Jul 30 2020, 12:04 AM
ppelberg claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 30 2020, 12:04 AM
Ryasmeen reopened this task as Open.Sep 18 2020, 8:27 PM

Reopening since this still happens sometimes for me.

Reopening since this still happens sometimes for me.

@Ryasmeen: are you able to upload a video of the behavior you're experiencing?

...I'm following the instructions listed in T258988#6342883 and I have not yet had any difficulty opening VE: https://youtu.be/3gdCrDbMyDA.

Hey @Ryasmeen can you add a video of the behavior

JTannerWMF moved this task from Inbox to High Priority on the Editing QA board.Sep 23 2020, 5:24 PM

So it starts with a crash while adding a map to the page and then it does not recover from that state.

ppelberg renamed this task from [Regression pre-wmf.2] VE is not opening on Beta cluster using Chrome to [Regression pre-wmf.2] Map dialog in VE hangs and VE does not open on page relaod.Sep 24 2020, 10:21 PM
ppelberg updated the task description. (Show Details)
ppelberg removed a project: User-Ryasmeen.
Esanders updated the task description. (Show Details)Sep 25 2020, 2:26 PM
Esanders added a comment.EditedSep 25 2020, 2:29 PM

The steps in T258988#6342883 will still trigger a full page reload when you go back to the read page, so I suspect it was just chance that this happened when you followed these steps. The fact it only breaks sometimes suggest there could be a race condition though, which would just result in it occurring seemingly randomly.

Do you see any errors in the console when it hangs? Or any failed requests in the network tab?

The steps in T258988#6342883 will still trigger a full page reload when you go back to the read page, so I suspect it was just chance that this happened when you followed these steps. The fact it only breaks sometimes suggest there could be a race condition though, which would just result in it occurring seemingly randomly.

Do you see any errors in the console when it hangs? Or any failed requests in the network tab?

No, there are no errors in the console. No failed requests in the network tab either.

Esanders renamed this task from [Regression pre-wmf.2] Map dialog in VE hangs and VE does not open on page relaod to [Regression pre-wmf.2] Map dialog in VE hangs and VE does not open on page reload.Sep 30 2020, 4:57 PM