Page MenuHomePhabricator

DiscussionTools tools appear in VE
Closed, ResolvedPublic

Description

In T258988, @Ryasmeen wrote:

I noticed an option "Mention a user" under Insert menu. Clicking on which was doing nothing but there was an error in the console.

I can reproduce this. It only happens on pages that load the reply tool (so talk pages, or when using dtenable=1).

Also, and this is probably related, it looks like the option to insert "Your signature" always appears regardless of the namespace.

Event Timeline

ppelberg created this task.Jul 28 2020, 3:08 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 28 2020, 3:08 PM

Also, and this is probably related, it looks like the option to insert "Your signature" always appears regardless of the namespace.

I think this is actually intentional, or at least not a recent regression. I just never noticed it before.

Change 616898 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/DiscussionTools@master] Do not auto-add "Mention a user" to "Insert" menu

https://gerrit.wikimedia.org/r/616898

Also, and this is probably related, it looks like the option to insert "Your signature" always appears regardless of the namespace.

I think this is actually intentional, or at least not a recent regression. I just never noticed it before.

Yeah, it's been like that for at least last 3 years. I knew it was intentionally added there. Forgot the the reason though.

Change 616898 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Do not auto-add "Mention a user" to "Insert" menu

https://gerrit.wikimedia.org/r/616898

JTannerWMF moved this task from Inbox to High Priority on the Editing QA board.Jul 29 2020, 5:25 PM
JTannerWMF added a subscriber: JTannerWMF.

Hey @Ryasmeen , we are in Board Refinement and @matmarex said he fixed this, so T258988 should no longer be blocked. Can you confirm this and move it to @ppelberg column if it is resolved or show him what you're running into if it is not during your 1:1?

Ryasmeen triaged this task as High priority.Jul 29 2020, 8:17 PM

This is now fixed and so are all the other issues I was running into in T258988.

This is now fixed and so are all the other issues I was running into in T258988.

Excellent. Thank you for confirming, Rummana.

ppelberg closed this task as Resolved.Jul 30 2020, 12:04 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 30 2020, 12:04 AM