Page MenuHomePhabricator

Watchlist Expiry: Add success message for action=watch [[XSMALL]]
Closed, ResolvedPublic

Description

As a Watchist Expiry user, I want the success message to be updated when I watch via action=watch, so that I can confirm that the time period I selected is accurate.

Acceptance Criteria:

  • Add same success message for action=watch as seen on other pages when user watches temporarily ("XX and its discussion page have been added to your watchlist for XX.")

Visual Example of Current Behavior for action=watch (we should change this):

Example of what users see when watching via star (for comparison):

Event Timeline

ifried created this task.Jul 28 2020, 5:22 PM
Restricted Application added a subscriber: Aklapper. ยท View Herald TranscriptJul 28 2020, 5:22 PM
ifried updated the task description. (Show Details)Jul 30 2020, 3:33 PM
ifried updated the task description. (Show Details)
ARamirez_WMF renamed this task from Watchlist Expiry: Add success message for action=watch to Watchlist Expiry: Add success message for action=watch [[XSMALL]].Jul 30 2020, 5:30 PM
ARamirez_WMF moved this task from To Be Estimated/Discussed to Estimated on the Community-Tech board.
dmaza removed dmaza as the assignee of this task.Aug 6 2020, 5:16 PM
dmaza added a subscriber: dmaza.

Change 619168 had a related patch set uploaded (by Samwilson; owner: Samwilson):
[mediawiki/core@master] Correct success messages for action=watch

https://gerrit.wikimedia.org/r/619168

Change 619168 merged by jenkins-bot:
[mediawiki/core@master] Correct success messages for action=watch

https://gerrit.wikimedia.org/r/619168

@Samwilson I find with a non-English interface language the success message is always in days.

For example, in French:


@ifried For a page you are already watching, if you submit action=watch without changing the expiry dropdown the success message will report the number of days rounded up. However, in reality the expiry date has not been changed. This might be misleading.

For example, the watch for this page expires in about 1 day 12 hours, but the success page reports 2 days (but in reality the expiry is not changed):

I am not sure if this matters. I am not sure under which circumstance you would submit action=watch without changing the expiry (it would seem to be pointless).

ifried added a subscriber: Prtksxna.EditedSep 4 2020, 6:48 PM

@dom_walden Thanks for pointing this out! I have 2 questions:

  1. Does this only occur when the user is seeing the success message on action=watch after already watching a page temporarily?
  2. In all other cases, does the success message round down rather than up? My personal opinion is that it's probably better to round down, since users don't want to miss out on a page expiring earlier than they expected (basically, "better safe than sorry"). I think we discussed this in the past, but perhaps this wasn't recorded in a Phabricator ticket. Do you agree with this analysis, @Prtksxna?

Overall, if this only shows up in the user flow you described, then this is indeed an edge case, and I think it can be addressed in a separate ticket. It wouldn't need to block the progress of this ticket.

Here's why: While some users may choose to visit action=watch in order to edit a watch selection, I think this would be pretty uncommon, since it's a) less user-friendly than editing a watch period via star or source editor dropdown, and b) it's not easily accessible in the UI (since right-clicking on the star for watched pages brings the user to action=unwatch). However, if the success message behavior is indeed different than in other cases, we should fix the behavior in a separate ticket. Thanks!

  1. In all other cases, does the success message round down rather than up? My personal opinion is that it's probably better to round down, since users don't want to miss out on a page expiring earlier than they expected (basically, "better safe than sorry"). I think we discussed this in the past, but perhaps this wasn't recorded in a Phabricator ticket. Do you agree with this analysis, @Prtksxna?

Yep, I completely agree with your proposal and reasoning.

  1. Does this only occur when the user is seeing the success message on action=watch after already watching a page temporarily?

I think so. I have not reproduced it any other way.

I guess in theory, for a page you are not watching, you could "hack" the HTML to submit a value like "1 day 1 hour" and it would round up to "2 days". However, I have tried this and I get a validation error and the form does not submit.

  1. In all other cases, does the success message round down rather than up? My personal opinion is that it's probably better to round down, since users don't want to miss out on a page expiring earlier than they expected (basically, "better safe than sorry"). I think we discussed this in the past, but perhaps this wasn't recorded in a Phabricator ticket. Do you agree with this analysis, @Prtksxna?

It always rounds up.

ifried added a comment.EditedSep 8 2020, 3:07 PM

@dom_walden Okay, thanks for letting me know! I have written a placeholder ticket, where we can separately address the rounding up vs. down issue: T262286.

Note: As I think about the rounding issue further, I think it is relatively low priority, since: a) if the user is watching for 1 day and 1 hour, it *is* still technically 2 days, or at least over 1 day, b) it appears that it is presented in a standard way in all cases, and c) we have a way to reducing confusion when there is less than 1 day left (we write "a few hours left"). We can wait from feedback from users, once the feature is enabled, to determine if any further action should be taken.

Change 626253 had a related patch set uploaded (by HMonroy; owner: Samwilson):
[mediawiki/core@REL1_35] Correct success messages for action=watch

https://gerrit.wikimedia.org/r/626253

Change 626253 merged by jenkins-bot:
[mediawiki/core@REL1_35] Correct success messages for action=watch

https://gerrit.wikimedia.org/r/626253

Watching permanently:

Watching temporarily, when choosing one of the four options from the dropdown, expiry is in weeks or months:

Watching temporarily, when expiry value does not match the four options in the dropdown, expiry is in days:

Watching for less than 1 day:

With watchlist expiry disabled, the success message is just the same as before for article and talk pages.

@Samwilson I find with a non-English interface language the success message is always in days.

Raised as T262547.

Other issues appear to have been answered/addressed in follow up bugs. Ready to move on.

ifried closed this task as Resolved.Sep 10 2020, 10:00 PM

We will address T262547 separately. I have tested the behavior, and the success message is now displaying in the action=watch page (see screenshot example below). I'm marking this work as Done.