Page MenuHomePhabricator

upgrade 1.34.2 to 1.35.0-rc.0 fails
Closed, DuplicatePublic

Description

Trying to update a test wiki running 1.34.2 and executing maintenance/update.php, I get

`wikimedia/parsoid: 0.12.0-a22 installed, 0.12.0-a23 required.
Error: your composer.lock file is not up to date. Run "composer update --no-dev" to install newer dependencies
can't execute update script on wiki-t05.hrz.uni-bielefeld.de: Interrupted system call`

It is unclear to me what I should do, I don't see a script/executable "composer". And it would be great if the installer could handle this on it's own.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 3 2020, 6:53 AM

I think it related to T259402.

Legoktm added a subscriber: Legoktm.Aug 3 2020, 7:31 AM

Indeed, this was a bug in rc.0, has been fixed in git and will be part of rc.1.