Page MenuHomePhabricator

CU 2.0: GuidedTour only highlights one row, even if there are other matching rows
Closed, ResolvedPublic3 Estimated Story PointsAug 25 2020

Description

What is the problem?

When viewing the GuidedTour, steps 1, 2 and 3 automatically highlight one (UA or IP) cell in the table. However, if there are other rows which match, these are not highlighted. See screenshot.

This might confuse users as to how highlighting actually works.

Originally raised in T255644#6319850. Raising here just in case we miss it.

Screenshots (if applicable):

Acceptance criteria:
  • All rows with same matching UA/IP are highlighted (not just the one cell). The cell being highlighted in darker yellow (#fc3?) and the rest of the cells in the row are the lighter shade (#fef6e7?)

Event Timeline

Restricted Application added a subscriber: Aklapper. ยท View Herald TranscriptAug 8 2020, 11:24 AM
Niharika triaged this task as Medium priority.Aug 12 2020, 4:35 AM
Niharika updated the task description. (Show Details)
ARamirez_WMF set the point value for this task to 3.Aug 12 2020, 4:23 PM
ARamirez_WMF changed the subtype of this task from "Bug Report" to "Deadline".Aug 12 2020, 8:53 PM
ARamirez_WMF set Due Date to Aug 25 2020, 4:00 AM.

Change 620773 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[mediawiki/extensions/CheckUser@master] Highlight matching rows in guided tour on Special:Investigate

https://gerrit.wikimedia.org/r/620773

Change 620773 merged by jenkins-bot:
[mediawiki/extensions/CheckUser@master] Highlight matching rows in guided tour on Special:Investigate

https://gerrit.wikimedia.org/r/620773

All the matching IP or UA cells get highlighted in steps 1, 2 and 3.

Doing comparisons of the HTML before and after the tour, the table appears to be returned to normal when you dismiss the tour. E.g. the table cells have the correct classes.

Otherwise, GuidedTour behaves as before.


Prtksxna added a subscriber: Prtksxna.

All rows with same matching UA/IP are highlighted (not just the one cell). The cell being highlighted in darker yellow (#fc3?) and the rest of the cells in the row are the lighter shade (#fef6e7?)

I don't see the lighter shade on the highlighted row.
Created T261088: CU 2:0: GuidedTour highlighted row should have faded yellow

Thanks @Prtksxna and @dom_walden. Looks like this (briefly) worked after the original patch, but there was a regression with a later patch: T261088#6406303

Moving this on, since we have a follow-up task for this now.

Niharika closed this task as Resolved.Sep 26 2020, 9:14 AM