Page MenuHomePhabricator

Input mic icon overlap with placeholder text in RTL language
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  1. KaiOS phone, set the UI language to RTL
  2. Go to Search Screen

Actual Results:

  1. The icon on the right overlap with the input placeholder text

Expected Results:

Example 1Example 2
NOTE: This is KaiOS phone screenshot, Jio 1 and Jio 2 don't have the icon within input form.

Event Timeline

hueitan created this task.Aug 11 2020, 9:17 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 11 2020, 9:17 AM
Jpita added a subscriber: Jpita.Aug 11 2020, 9:46 AM

jio 2 doesn't have the icon because it has a dedicated button to bring up the mic feature

hueitan updated the task description. (Show Details)Aug 11 2020, 9:50 AM
hueitan updated the task description. (Show Details)Aug 11 2020, 10:04 AM

to dev : simply adding padding-right to the input form doesn't work as expected

hueitan updated the task description. (Show Details)Aug 11 2020, 10:08 AM
AMuigai moved this task from Bugs to Q2-2020 on the Inuka-Team board.Aug 17 2020, 6:20 PM
SBisson triaged this task as Medium priority.Sep 15 2020, 7:07 PM

I can't see it in action. None of my devices have the mic icon (Jio1, Jio2, Nokia 4110).

@hueitan do you see it anywhere else on this phone in apps that have input boxes? Maybe the browser or any app that has a search feature?

Restricted Application added a project: I18n. · View Herald TranscriptSep 16 2020, 5:59 AM

This is how the others show the mic icon

MessageBrowser

We should do the same

hueitan updated the task description. (Show Details)Sep 16 2020, 2:50 PM

Interesting. There's a dir="rtl" missing somewhere for the input to place the mic icon at the end (left, in this case) of the field.

@hueitan I think this task is going to be for you since you are the only engineer with this device.

hueitan claimed this task.Sep 16 2020, 3:07 PM
hueitan moved this task from Backlog to Dev on the Inuka-Team (Kanban) board.
hueitan moved this task from Dev to Code Review on the Inuka-Team (Kanban) board.Sep 21 2020, 8:37 AM
Amire80 renamed this task from Input icon overlap with placeholder text in RTL language to Input mic icon overlap with placeholder text in RTL language.Sep 22 2020, 6:00 AM
SBisson moved this task from Code Review to QA on the Inuka-Team (Kanban) board.Sep 22 2020, 12:29 PM
Jpita moved this task from QA to Design sign off on the Inuka-Team (Kanban) board.Oct 5 2020, 3:35 PM
AMuigai closed this task as Resolved.Oct 6 2020, 1:01 PM