Page MenuHomePhabricator

cirrussearch-backend-error: Called from Wikibase\Search\Elastic\EntitySearchElastic::getRankedSearchResults
Closed, ResolvedPublicPRODUCTION ERROR

Description

Error

MediaWiki version: 1.36.0-wmf.4

message
PHP Warning: {"type":"error","message":"cirrussearch-backend-error","params":[]} [Called from Wikibase\Search\Elastic\EntitySearchElastic::getRankedSearchResults in /srv/mediawiki/php-1.36.0-wmf.4/extensions/WikibaseCirrusSearch/src/EntitySearchElastic.php at line 318]

Impact

One of these seen for 1.36.0-wmf.4

Notes

Details

Request ID
c2f488ef-00ed-4b08-951b-9293d7303872
Request URL
https://www.wikidata.org/w/api.php?action=wbsearchentities&format=json&origin=https%3A%2F%2Fcommons.wikimedia.org&search=xxxx&language=en&uselang=en&type=item&limit=7
Stack Trace
exception.trace
#0 [internal function]: MWExceptionHandler::handleError(integer, string, string, integer, array)
#1 /srv/mediawiki/php-1.36.0-wmf.4/includes/debug/MWDebug.php(452): trigger_error(string, integer)
#2 /srv/mediawiki/php-1.36.0-wmf.4/includes/debug/MWDebug.php(196): MWDebug::sendMessage(string, string, integer)
#3 /srv/mediawiki/php-1.36.0-wmf.4/includes/GlobalFunctions.php(1087): MWDebug::warning(string, integer, integer, string)
#4 /srv/mediawiki/php-1.36.0-wmf.4/extensions/WikibaseCirrusSearch/src/EntitySearchElastic.php(318): wfLogWarning(string)
#5 /srv/mediawiki/php-1.36.0-wmf.4/extensions/Wikibase/repo/includes/Api/CombinedEntitySearchHelper.php(52): Wikibase\Search\Elastic\EntitySearchElastic->getRankedSearchResults(string, string, string, integer, boolean)
#6 /srv/mediawiki/php-1.36.0-wmf.4/extensions/Wikibase/repo/includes/Api/TypeDispatchingEntitySearchHelper.php(55): Wikibase\Repo\Api\CombinedEntitySearchHelper->getRankedSearchResults(string, string, string, integer, boolean)
#7 /srv/mediawiki/php-1.36.0-wmf.4/extensions/Wikibase/repo/includes/Api/ConceptUriSearchHelper.php(36): Wikibase\Repo\Api\TypeDispatchingEntitySearchHelper->getRankedSearchResults(string, string, string, integer, boolean)
#8 /srv/mediawiki/php-1.36.0-wmf.4/extensions/Wikibase/repo/includes/Api/SearchEntities.php(131): Wikibase\Repo\Api\ConceptUriSearchHelper->getRankedSearchResults(string, string, string, integer, boolean)
#9 /srv/mediawiki/php-1.36.0-wmf.4/extensions/Wikibase/repo/includes/Api/SearchEntities.php(238): Wikibase\Repo\Api\SearchEntities->getSearchEntries(array)
#10 /srv/mediawiki/php-1.36.0-wmf.4/extensions/Wikibase/repo/includes/Api/SearchEntities.php(224): Wikibase\Repo\Api\SearchEntities->executeInternal()
#11 /srv/mediawiki/php-1.36.0-wmf.4/includes/api/ApiMain.php(1593): Wikibase\Repo\Api\SearchEntities->execute()
#12 /srv/mediawiki/php-1.36.0-wmf.4/includes/api/ApiMain.php(529): ApiMain->executeAction()
#13 /srv/mediawiki/php-1.36.0-wmf.4/includes/api/ApiMain.php(500): ApiMain->executeActionWithErrorHandling()
#14 /srv/mediawiki/php-1.36.0-wmf.4/api.php(90): ApiMain->execute()
#15 /srv/mediawiki/php-1.36.0-wmf.4/api.php(45): wfApiMain()
#16 /srv/mediawiki/w/api.php(3): require(string)
#17 {main}

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 12 2020, 6:55 PM
Restricted Application added a project: Wikidata. · View Herald TranscriptAug 19 2020, 6:54 PM

This bit of code includes the comment

// FIXME: this is a hack, we need to return Status upstream instead

The value that is being logged here was intended for end users, it provides an i18n message to tell the user what went wrong. In this case there was a failure communicating with the backend service. Failure rates are already tracked and alerted on, the log message here is unactionable.

Tempted to simply drop the code that logs these. It was trying to make sure it didn't simply ignore the error, but amounts to spamming up logs with messages for the end user.

Change 621584 had a related patch set uploaded (by Ebernhardson; owner: Ebernhardson):
[mediawiki/extensions/WikibaseCirrusSearch@master] Don't log end user error messages

https://gerrit.wikimedia.org/r/621584

Change 621584 merged by jenkins-bot:
[mediawiki/extensions/WikibaseCirrusSearch@master] Don't log end user error messages

https://gerrit.wikimedia.org/r/621584

Krinkle closed this task as Resolved.Sep 3 2020, 8:43 PM
Krinkle added a subscriber: Krinkle.

Confirmed gone from Logstash after Aug 26.