Page MenuHomePhabricator

"TypeError: Cannot read property 'linterrors' of undefined" when replying to a comment
Closed, ResolvedPublic

Description

I got this error message when trying to reply to a post on https://ko.wikipedia.org/wiki/위키백과:사랑방_%28기술%29.

TypeError: Cannot read property 'linterrors' of undefined


I've seen it before in T259855#6369023.

Event Timeline

matmarex created this task.Aug 12 2020, 9:29 PM
Restricted Application added subscribers: revi, Aklapper. · View Herald TranscriptAug 12 2020, 9:29 PM

This is a bug in our error handling only. It seems to only happen when you're supposed to see a different error (e.g. in my testing, the real error being hidden by this is "Error contacting the Parsoid/RESTBase server (HTTP 500)", which is probably T260180/T236866).

Change 619857 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/DiscussionTools@master] Fix error handling in controller#getPageData

https://gerrit.wikimedia.org/r/619857

Change 619857 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Fix error handling in controller#getPageData

https://gerrit.wikimedia.org/r/619857

@matmarex: the "Error contacting the Parsoid/RESTBase server (HTTP 500)" language, which I understand this patch "re-instates"/ensures is properly displayed, how did that language come to be?

...I ask thinking any person encountering that error message is not likely to know what it means or what they can do to resolve it.

I appreciate any changes that result from the answer to the question above are likely out of scope for this task.

The error message was added in https://gerrit.wikimedia.org/r/c/mediawiki/extensions/VisualEditor/+/544152, replacing a message that would just say "HTTP 500" with no context.

Generally, a person seeing this error can't do anything to resolve it. It's only caused by bugs in our code or our configuration.

The message exist only so that they have something concrete to refer to, e.g. when reporting the bug, and so that we can tell which error condition they ran into (that's why it's not something entirely vague like "Something went wrong").

ppelberg closed this task as Resolved.Aug 29 2020, 12:53 AM

The error message was added in https://gerrit.wikimedia.org/r/c/mediawiki/extensions/VisualEditor/+/544152, replacing a message that would just say "HTTP 500" with no context.

Generally, a person seeing this error can't do anything to resolve it. It's only caused by bugs in our code or our configuration.

The message exist only so that they have something concrete to refer to, e.g. when reporting the bug, and so that we can tell which error condition they ran into (that's why it's not something entirely vague like "Something went wrong").

This context is helpful – thank you for sharing it, @matmarex.

I'd like us to consider revising this message. Here is a task for that work: T261538