Page MenuHomePhabricator

Reduce duplication between the preview states in preview.js
Closed, ResolvedPublic

Description

The file preview.js contains the rendering code for the 5 states of the preview: standard, loading, error, disambiguation, offline. They have almost identical chrome and layout but the markup and style are duplicated.

Find a clean way to reuse parts to reduce code size and maintenance burden.

Event Timeline

SBisson created this task.Aug 13 2020, 3:08 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 13 2020, 3:08 PM
AMuigai moved this task from Backlog to Q2-2020 on the Inuka-Team board.Aug 20 2020, 1:25 PM
SBisson moved this task from Q2-2020 to Kanban on the Inuka-Team board.Oct 5 2020, 7:15 PM
SBisson edited projects, added Inuka-Team (Kanban); removed Inuka-Team.
SBisson renamed this task from Reduce duplication between the 4 preview states in preview.js to Reduce duplication between the preview states in preview.js.Oct 6 2020, 1:01 PM
SBisson updated the task description. (Show Details)
eamedina claimed this task.Oct 19 2020, 8:16 PM
eamedina moved this task from Ready for Dev to Dev on the Inuka-Team (Kanban) board.
eamedina moved this task from Dev to Code Review on the Inuka-Team (Kanban) board.Oct 20 2020, 8:47 PM
hueitan moved this task from Code Review to QA on the Inuka-Team (Kanban) board.Oct 27 2020, 8:39 AM
Jpita added a subscriber: Jpita.

I found this issues while testing this but since this PR is merged, do I create a new task or a new PR is added here?

  • the try again button doesn't update the content

  • the language of the error is different from the one in the link

I found this issues while testing this but since this PR is merged, do I create a new task or a new PR is added here?

Hard to tell if those issues are caused by this task or another one since several PRs have been merged recently. I recommend filing new bug(s).

AMuigai closed this task as Resolved.Nov 5 2020, 12:25 PM