Page MenuHomePhabricator

Prepare and check storage layer for jawikivoyage
Closed, ResolvedPublic

Description

The new wiki is going to be public.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 15 2020, 4:53 PM
JJMC89 moved this task from Backlog to Wiki replicas on the Data-Services board.Aug 15 2020, 5:04 PM
Marostegui triaged this task as Medium priority.Aug 17 2020, 5:27 AM
Marostegui moved this task from Triage to Blocked external/Not db team on the DBA board.
Marostegui added a subscriber: Marostegui.

Just a reminder, new wikis go to s5 now instead of s3.
Let us know when the DB is created so we can sanitize it.

Mentioned in SAL (#wikimedia-operations) [2020-08-31T07:12:02Z] <marostegui> Sanitize jawikivoyage on db2094:3325 and db1124:3325 T260482

Database has been sanitized.
Triggers have been tested with my user and they work fine.
jawikivoyage_p has been created on all hosts.
Grants have been added to labsdb1009, 1010, 1011 and 1012

I am running a check private data again to make sure it is fully clean before sending it for the views creation.

Marostegui moved this task from In progress to Done on the DBA board.Mon, Aug 31, 2:03 PM
Marostegui added subscribers: Bstorm, bd808, nskaggs.

check private data finished clean. This is ready for cloud-services-team for the views creation on the 4 hosts.

jhsoby added a subscriber: jhsoby.Tue, Sep 8, 7:28 AM

Search is still not working on the Japanese Wikivoyage. I believe it could be related to this task (but I'm not quite sure, since I don't really know what "check storage layer" actually means). If so, what's the delay here?

jcrespo added a subscriber: jcrespo.Tue, Sep 8, 7:33 AM

@jhsoby this task only relates to cloud infrastructure- it won't make search (or anything else) work on a wiki. I suggest you reopen T260320 and report there.

nskaggs closed this task as Resolved.Wed, Sep 9, 9:04 PM
nskaggs claimed this task.

Views created.

@jhsoby this task only relates to cloud infrastructure- it won't make search (or anything else) work on a wiki. I suggest you reopen T260320 and report there.

Thanks, I was confused then. I'll open a new task for this instead.

Thanks, I was confused then. I'll open a new task for this instead.

Thank you, that would work too. Sorry for any inconveniences caused by an ongoing bug- even if we dbas and cloud people were not involved in its creation. Please create such a task so it can be seen by the right people and hopefully fixed soon.