Page MenuHomePhabricator

Wikidata – Font size error on External Properties section in left tool bar
Closed, ResolvedPublicBUG REPORT

Description

This is a new bug as of 26 August 2020.

Steps to Reproduce:

  • Using Chrome browser
  • Using new Vector skin
  • External Properties set to appear in left tool bar

Actual Results:

Font size for external properties is too large

Expected Results:

Font size for external properties should be the same as other tools

Event Timeline

PKM created this task.Aug 26 2020, 10:04 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 26 2020, 10:04 PM
PKM updated the task description. (Show Details)Aug 26 2020, 10:05 PM
Mbch331 added a subscriber: Mbch331.

I've just checked https://www.wikidata.org/wiki/Q98668689 and I don't see the External Properties section. Neither logged in, nor logged out. So it looks like this was added by a gadget/user script. That means the gadget/user script doesn't add the right classes.
Can you tell which gadget/user script adds this section?

I think it's a user script. This looks like the one in https://www.wikidata.org/w/index.php?title=User:PKM/common.js:

importScript('User:Magnus Manske/ext-props.js');

Mbch331 added a subscriber: Magnus.

It is indeed that script by @Magnus.
It looks bad too using Legacy Vector, so Magnus has to check/fix this. Isn't related to the new Vector skin that is being developed.
@PKM it is best to leave a note on Magnus' talkpage as well.

Patriccck renamed this task from Wikidata - Font size error on External Properties section in left tool bar to Wikidata – Font size error on External Properties section in left tool bar.Aug 27 2020, 11:20 AM
PKM added a comment.Aug 27 2020, 6:56 PM

Note left on Magnus's talk page, thanks for checking.

It’s caused by aa45edd2f29b81b059d6856e945011cccbd81545. The user script should use <div class='portal vector-menu-portal' instead of <div class='portal'.

PKM closed this task as Resolved.Tue, Oct 13, 8:28 PM
PKM claimed this task.

Magnus has fixed this. @Tacsipacsi, thanks for the direction.