Page MenuHomePhabricator

"In other projects" is big and not style aligned in some Italian projects (due to broken, local scripts loaded via MediaWiki:Vector.js)
Closed, InvalidPublicBUG REPORT

Description

In Italian wikiprojects the writing "In other projects" is strange and unusually big, with Vector skin. This was reported by some users not only in Italian Wikinews, Italian Wiktionary and Italian Wikipedia and with the Steward script on Safari last public version (mostly) and Chrome

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 28 2020, 12:57 PM
Reedy updated the task description. (Show Details)
Aklapper changed the task status from Open to Stalled.EditedAug 28 2020, 1:13 PM

Hi @Ferdi2005, thanks for taking the time to report this! I cannot reproduce in Firefox 80.0 when going to https://it.wikinews.org/wiki/Pagina_principale .

Please add a more complete description to this task. That should always be

  • a clear and complete list of exact steps to reproduce the situation, step by step, so that nobody needs to guess or interpret how you performed each step, including full URLs,
  • what happens after performing these steps to reproduce,
  • what you expected to happen instead,
  • a full link to a web address where the issue can be seen,
  • the web browser(s) and web browser version(s) that you tested.

Thanks!

Wim_b added a subscriber: Wim_b.Aug 28 2020, 4:07 PM

@Aklapper also whit the steward script ( https://meta.wikimedia.org/wiki/StewardScript ) and Vector skin, whit monobook the problem does not arise.

I use:

  • Safari Vers. 13.1.2 (15609.3.5.1.3)
  • Chrome Vers. 84.0.4147.135 (Official Build 64 bit)
Ferdi2005 changed the task status from Stalled to Open.EditedAug 28 2020, 7:33 PM

Safari last version on macOS and iOS. This happens on some page, I can’t identify the pattern, for example https://it.wikinews.org/wiki/Wikinotizie:Bar from the screenshot.
STEP TO REPRODUCE:

Ferdi2005 added a comment.EditedAug 28 2020, 7:35 PM

This also happens on italian Wikipedia in the page https://it.wikipedia.org/wiki/Progetto:GLAM/Museoscienza

So now we are at three (two mine + 1 from wiktionary) pages and a script, on different browsers and wikis.

Reedy added a subscriber: Reedy.

Safari version 13.1.2 (15609.3.5.1.3) on 10.15.6

@Reedy for Wim B this also happens on Chrome.

Ferdi2005 updated the task description. (Show Details)
Ferdi2005 updated the task description. (Show Details)

@Reedy so the problems happens also to you, see that big strange wikispecies that is doubled. Could you please send a full screenshot so it’s more visible?

Ferdi2005 updated the task description. (Show Details)Aug 28 2020, 7:40 PM
Reedy added a comment.Aug 28 2020, 7:42 PM

If you click on it, it'll show you a larger version

Same issue on Edge version 84.0.522.63 (64 bit)


Wim_b added a comment.EditedAug 28 2020, 7:59 PM

A random page from it.wikipedia.
This problem appear whit vector skin…

And this in page "casa" on it.wikiquote.

In my case "sister project" and "altre lingue" (other language) are normal size, but steward script's menu i too large.

Jdlrobson closed this task as Invalid.EditedAug 28 2020, 8:51 PM
Jdlrobson edited projects, added Reading-Web-Local-Wiki-Issues; removed Vector.
Jdlrobson added a subscriber: Jdlrobson.

I can reproduce, but not with safemode on - https://it.wikinews.org/wiki/Wikinotizie:Bar?safemode=1 or with JS disabled - which tells me this is a user gadget and
this needs to be fixed on wiki. Please use the community portals so find out what steward script is causing this problem.

The offending script seems to be creating #p-iproject in an incompatible (and unsupported) way inside:
https://it.wikinews.org/wiki/MediaWiki:Vector.js

Either fix or empty that script.

I have not steward scripts and someone saw it as unlogged. @Jdlrobson

This is not only on it.wikinews.

Reedy added a comment.Aug 28 2020, 9:12 PM

This is not only on it.wikinews.

Doesn't really matter. Scripts get copied (or included) onto multiple wikis, so chances are the same fix might be needed in multiple places

Jdlrobson added a comment.EditedAug 28 2020, 10:54 PM

I have not steward scripts and someone saw it as unlogged. @Jdlrobson

https://it.wikinews.org/wiki/MediaWiki:Vector.js runs for unlogged (anonymous) users.

This is not only on it.wikinews.

For Wikitionary and Wikipedia both projects load https://it.wikipedia.org/wiki/MediaWiki:InterProject.js and https://it.wiktionary.org/wiki/MediaWiki:InterProject.js via their Common.js

All these issues will need to be taken up on the associated talk pages and relevant technical Portale Comunità. Those are community managed scripts.

Aklapper renamed this task from "In other projects" is big and not style aligned in Italian projects to "In other projects" is big and not style aligned in some Italian projects (due to broken, local scripts loaded via MediaWiki:Vector.js).Aug 29 2020, 12:05 PM
Base added a subscriber: Base.Sep 2 2020, 1:10 AM