Page MenuHomePhabricator

Messages of log entries should support GENDER
Closed, ResolvedPublic

Description

Author: Eugene.Zelenko

Description:
It's necessary to pass user name into this message to support GENDER.

On Slavic language there is different translation depending on gender of user who performed action.

I think other messages related to logs are possible candidate to such changes, where user name linked in software with other message and past time is used in message itself.


Version: unspecified
Severity: enhancement

Details

Reference
bz24156

Related Objects

StatusAssignedTask
ResolvedUmherirrender
OpenNone
Declinedsiebrand
Resolved Fabrice_Florin
Resolvedmatthiasmullie
ResolvedUmherirrender
ResolvedUmherirrender
ResolvedUmherirrender
ResolvedNone
ResolvedUmherirrender
OpenNone
ResolvedGlaisher
OpenNone
ResolvedGlaisher
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
ResolvedGlaisher
Resolvedmatej_suchanek
ResolvedGlaisher

Event Timeline

bzimport raised the priority of this task from to High.Nov 21 2014, 11:05 PM
bzimport set Reference to bz24156.
bzimport created this task.Jun 28 2010, 2:00 PM

danny.leinad wrote:

I've changed summary of bug - in Polish most of messages in log need GENDER support.

For example:

  • [[MediaWiki:Deletedarticle]]
    • male: usunął $1
    • female: usunęła $1
  • [[MediaWiki:Blocklogentry]]
    • male: zablokował $1, czas blokady: $2 $3
    • female: zablokowała $1, czas blokady: $2 $3
  • [[MediaWiki:Abusefilter-log-entry-modify]]
    • male: zmodyfikował $1 ($2)
    • female: zmodyfikowała $1 ($2)

etc

Ties in with bug 21716 and bug 25351. Sounds like a project.

While you look at these, maybe having an eye on another problem at the same time may help to structurally better solutions. Details in bug 27743.

A question from a silly user who knows very little about the MediaWiki source code: Is there anything here to be done except passing the username as a parameter?

To Niklas per IRC triage.

See also Bug 30737

Yeah, Russian translations also need support for {{GENDER}}, some messages:

  • blocklogentry.
  • Prot_1movedto2.
  • blocked-notice-logextract.
  • ipb-disableusertalk.
  • ipb-needreblock.
  • Accountcreatedtext.
  • Movedarticleprotection.

Incomplete list, got to go :(

Continue this list:

  • All Babel related messages ("This user is able to contribut...", "user" is gender-dependent in Russian translations).
  • Unblocklogentry.
  • Feedback-bugornote.
  • renameuserlogentry.
  • Undelete-revision.
  • blocked-notice-logextract.
  • renameuser-renamed-notice.
  • renameusersuccess.
  • sp-contributions-blocked-notice.

Also message group "group-...-member".

This bug is about log entries, some of which already support gender. group-* messages already support gender.

danny.leinad wrote:

Hi, I was going to check what new in MW 1.19 and I have just found that GENDER support for log entries has been removed :(

http://svn.wikimedia.org/viewvc/mediawiki/trunk/phase3/languages/messages/MessagesPl.php?r1=110867&r2=110909

Are you going to fix this problem?

danny.leinad wrote:

Dunno what's going on... I mean r110909

I'm planning to fix the problem for 1.20.

(In reply to comment #14)

I'm planning to fix the problem for 1.20.

Did you still working on this for 1.20? Thanks.

As this is only one of my pet projects, it gets pushed farther when other stuff comes up, haven't had that much time for other stuff lately, so help would be appreciated.

(In reply to comment #16)

As this is only one of my pet projects, it gets pushed farther when other stuff
comes up, haven't had that much time for other stuff lately, so help would be
appreciated.

With gerrit 4506 one part was already done, because with that change the GENDER parser function is using the GenderCache and that Cache is filled by the LinkBatch which is already there. In the most case the gender state will be already populated for the log and not generating one query per parser function call.

  • Bug 35809 has been marked as a duplicate of this bug. ***

Tim, can you have a look at this?

You have removed the GENDER from all log message with r110909, due to performance reason.
In the meantime things changed, see comment 17, maybe it is possible to put the GENDER back?

Thanks.

Adjusting priority field according to real needs.
This is a hard fix, apparently, bug this doesn't make it less needed; it's one of the most needed ones.
Also setting 1.21 as milestone (it would probably be one of main achievements for the release).

(In reply to comment #19)

Tim, can you have a look at this?
You have removed the GENDER from all log message with r110909, due to
performance reason.
In the meantime things changed, see comment 17, maybe it is possible to put the
GENDER back?

p.selitskas wrote:

Is it safe to bring GENDER to the messages back? Does the GenderCache work properly so there is no unreasonable overhead? If so, I can do it, just give me an update.

(In reply to comment #20)

Adjusting priority field according to real needs.
it's one of the most needed ones.

I understand this is very annoying for specific languages, but I'd love to see arguments listed in this bug report when enhancement requests get bumped to high priority and nobody is assigned to them yet. Comment 10 and comment 17 imply that support is in places for some cases (if I don't get it wrong).

(In reply to comment #22)

(In reply to comment #20)

Adjusting priority field according to real needs.
it's one of the most needed ones.

I understand this is very annoying for specific languages, but I'd love to
see
arguments listed in this bug report

Arguments: general guideline/policy https://www.mediawiki.org/wiki/Localisation#Users_have_grammatical_genders

when enhancement requests get bumped to
high priority and nobody is assigned to them yet.

"High priority" now means "within six months if possible", so it's surely not excessive.

Comment 10 and comment 17
imply that support is in places for some cases (if I don't get it wrong).

Comment 10 is before everything was reverted, and comment 17 only mentions a change that should help reverting the revert. Nothing was done yet.

Nobody reverts Tim Starling reverts ;-), so we need him, that he can say, if the revert of the revert would be safe and not bring to many load at wmf servers, when genders allows on log messages.

I have readd the gender to english logentry messages with gerrit 54143

Some languages are already using gender, so why not all?

(In reply to comment #25)

I have readd the gender to english logentry messages with Gerrit change
#54143

successfully merged

All log types rewritten with the LogFormatter can now use GENDER in the translation.

(In reply to comment #26)

successfully merged
All log types rewritten with the LogFormatter can now use GENDER in the
translation.

So can this report be closed as FIXED, or which steps are missing?

p.selitskas wrote:

(In reply to comment #27)

(In reply to comment #26)

successfully merged
All log types rewritten with the LogFormatter can now use GENDER in the
translation.

So can this report be closed as FIXED, or which steps are missing?

GENDER seems working in log entries, although I cannot say anything about perfomance.

Not all log types are rewritten with the LogFormatter, so not all log types supports gender. It looks easier to close this and use other bugs (some exists!?) for the log rewrite of other log types.

(In reply to comment #29)

Not all log types are rewritten with the LogFormatter, so not all log types
supports gender. It looks easier to close this and use other bugs (some
exists!?) for the log rewrite of other log types.

Bug 24620 exists. :) It's currently marked as blocker of this bug (technically wrong if that's open and this is closed).