Page MenuHomePhabricator

CU 2.0: Log button inconsistently placed
Closed, ResolvedPublic2 Estimated Story PointsOct 6 2020

Description

What is the problem?

The Log button on the Special:Investigate front page is slightly differently aligned compared to how it appears during an investigation.

On the front page it is slightly lower and nearer the (?) help button.

Compare:

log_front.png (175×473 px, 8 KB)

With:

log_inner.png (173×472 px, 10 KB)

Event Timeline

Niharika triaged this task as Medium priority.Sep 9 2020, 4:43 PM
ARamirez_WMF changed the subtype of this task from "Bug Report" to "Deadline".Sep 30 2020, 4:05 PM
ARamirez_WMF set Due Date to Oct 6 2020, 4:00 AM.

Change 631797 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[mediawiki/extensions/CheckUser@master] SpecialInvestigate: Ensure consistent display of indicator buttons

https://gerrit.wikimedia.org/r/631797

Change 631797 merged by jenkins-bot:
[mediawiki/extensions/CheckUser@master] SpecialInvestigate: Ensure consistent display of indicator buttons

https://gerrit.wikimedia.org/r/631797

I cannot notice any visual differences between the buttons on the front page and during an investigation.

E.g.

buttons_front_resized.png (138×350 px, 7 KB)

buttons_invst.png (137×350 px, 6 KB)

I have only tested this on the Vector legacy and Vector new skins, assuming that that is what most people will use.

Test environment: Local vagrant MediaWiki 1.36.0-alpha (d14ce36); CheckUser 2.5 (f2ad4b8).