Page MenuHomePhabricator

Highlight interwiki for the language of homewiki of a user which has a global account
Closed, DeclinedPublic

Description

As mentioned at mw:Special:Code/MediaWiki/67281#c7412, it seems interesting to highlight at least the interwiki corresponding to the language of homewiki when a user has global account.

Details

Reference
bz24193

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 11:08 PM
bzimport set Reference to bz24193.
bzimport added a subscriber: Unknown Object (MLST).
He7d3r created this task.Jun 30 2010, 9:16 PM

deletesoftware wrote:

Can a user change his homewiki?

no they can't, homewiki isn't really used for anything anyway.

(In reply to p858snake from comment #2)

no they can't, homewiki isn't really used for anything anyway.

And it isn't because it's meaningless. I don't see how this could be done in core given that home wiki is a concept from CentralAuth extension, anyway the implementation being developed now is bug 64793 which is based on what languages people actually speak.

  • This bug has been marked as a duplicate of bug 64793 ***
Amire80 reopened this task as Open.May 16 2016, 12:33 PM
Amire80 edited projects, added ULS-CompactLinks; removed MediaWiki-Interface.
Amire80 added a subscriber: Amire80.

Reopening—this is actually not a bad idea. It can be one of the strategies for picking the suggested language in ULS.

He7d3r updated the task description. (Show Details)May 24 2016, 6:35 PM

Does not seem worth it to me. The information about homewiki is not readily available.

Nemo_bis removed a subscriber: Nemo_bis.Jun 7 2016, 10:50 AM
Amire80 closed this task as Declined.Oct 31 2017, 11:42 AM

I have to (mostly) agree with @Nikerabbit. The information about homewiki is kind of available at Special:CentralAuth, but it's not really reliable, and the top common languages area at the top should already include the user's most important languages.