Page MenuHomePhabricator

Implement a confirmation dialogue when closing the app
Closed, ResolvedPublic

Description

Issue

When a user uses the back key repeatedly, the app quits, but this behaviour is unexpected.

Request

Show a confirmation dialogue before closing the app for a better user experience

Copy/Message

Exit Wikipedia?
Are you sure you want to close the app?
LSK: Cancel
RSK: Exit

Event Timeline

Jpita created this task.Sep 8 2020, 8:53 AM
Restricted Application added a project: Inuka-Team. · View Herald TranscriptSep 8 2020, 8:54 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
hueitan added a subscriber: hueitan.Oct 5 2020, 8:28 AM

fyi, this is what in facebook app

AMuigai moved this task from Backlog to Kanban on the Inuka-Team board.Nov 9 2020, 12:11 PM
AMuigai edited projects, added Inuka-Team (Kanban); removed Inuka-Team.
AMuigai renamed this task from implement a confirmation dialogue when closing the kaios app to Implement a confirmation dialogue when closing the app.Nov 9 2020, 2:27 PM
AMuigai triaged this task as Medium priority.
AMuigai updated the task description. (Show Details)
AMuigai updated the task description. (Show Details)Nov 9 2020, 2:30 PM

Copy looks fine to me.

hueitan claimed this task.Nov 16 2020, 6:34 PM
hueitan moved this task from Ready for Dev to Dev on the Inuka-Team (Kanban) board.
hueitan added a comment.EditedNov 17 2020, 10:06 AM

Note: It requires update to our current confirm dialog UI

Current *1New

To be Confirmed :

*1 image here is another confirm dialog when navigate to the section within the same article, it has the CSK as the "confirm", but the new exit app confirm dialog has the RSK as the "confirm", do you want to make it a general confirm dialog or exception here?

@hueitan I would advise keeping the confirmation to RSK to avoid the accidental press and cancel to LSK. I also got a couple of questions for you.

  • Changing the dialog box's style would change it to other places(app language, article preview, etc.) as well?
  • Would it resize itself to accommodate translated copy?

@hueitan I would advise keeping the confirmation to RSK to avoid the accidental press and cancel to LSK. I also got a couple of questions for you.

OK, change to RSK

  • Changing the dialog box's style would change it to other places(app language, article preview, etc.) as well?

No, the confirm dialog exist only in two places (including one here)

  • Would it resize itself to accommodate translated copy?

Yes, It would auto extend the height of the message box

@hueitan I would advise keeping the confirmation to RSK to avoid the accidental press and cancel to LSK. I also got a couple of questions for you.

OK, change to RSK

  • Changing the dialog box's style would change it to other places(app language, article preview, etc.) as well?

No, the confirm dialog exist only in two places (including one here)

Ohk, got it.

  • Would it resize itself to accommodate translated copy?

Yes, It would auto extend the height of the message box

Great

I think the language for the softkeys here is a bit confusing: we ask "Are you sure you want to close the app?" and then we use "Close" in the LSK, but the latter doesn't exit the app and instead closes the message box. I think "Yes" (RSK) or "No" (LSK) wold be less confusing (we have softkey-yes and softkey-no already in qqq.json)

fyi, this is what in facebook app

Or "Cancel" (LSK) and "Exit" (RSK) like in the facebook example, that could work too.

Thoughts?

Good catch @eamedina , waiting confirmation.

@eamedina @hueitan let's use "Cancel" (LSK) and "Exit" RSK.

@eamedina @hueitan let's use "Cancel" (LSK) and "Exit" RSK.

@hueitan has this been addressed in the PR?

@hueitan has this been addressed in the PR?

Update in the PR https://github.com/wikimedia/wikipedia-kaios/pull/283

SBisson moved this task from Code Review to QA on the Inuka-Team (Kanban) board.Nov 30 2020, 6:22 PM

The PR is merged

@hueitan is it possible to center the "Exit Wikipedia" text in the header area? On the banana phone device, the tail of "p" is touching the main text area. Also, can we increase the height of the dialog box to a couple of pixels? as of now, it looks a bit busy.

Jpita added a comment.Dec 9 2020, 1:20 PM

@hueitan is it possible to center the "Exit Wikipedia" text in the header area? On the banana phone device, the tail of "p" is touching the main text area. Also, can we increase the height of the dialog box to a couple of pixels? as of now, it looks a bit busy.

why do we use "close" and "exit"?
shouldn't we use the same word?

@hueitan is it possible to center the "Exit Wikipedia" text in the header area? On the banana phone device, the tail of "p" is touching the main text area.

Yes! I saw that now!

Also, can we increase the height of the dialog box to a couple of pixels? as of now, it looks a bit busy.

The height of the dialog box is based on the content size, we can adjust the margin/padding of the content. and of course we can make the exception here, but what's UI in your mind right now?

Yeah, I agree with @Jpita.

Jpita added a comment.Dec 9 2020, 3:11 PM

@hueitan are you going to change the copy?
should I move it back to dev?

Make sense @Jpita, @hueitan how about we make this to "Are you sure you want to exit the app? Also, I am happy to jump on a call to tweak the margin/padding of the dialog box to see how it looks?

Jpita moved this task from QA to Dev on the Inuka-Team (Kanban) board.Dec 9 2020, 3:30 PM

moving this to dev since it seems there will be some work (change a string) to be done

hueitan moved this task from Dev to Code Review on the Inuka-Team (Kanban) board.Dec 10 2020, 9:45 AM
SBisson moved this task from Code Review to QA on the Inuka-Team (Kanban) board.Dec 10 2020, 1:42 PM

The follow up PR is merged

Jpita moved this task from QA to Design sign off on the Inuka-Team (Kanban) board.Dec 10 2020, 3:25 PM
AMuigai closed this task as Resolved.Dec 11 2020, 11:53 AM