Page MenuHomePhabricator

Z[X(...)] is undefined
Closed, ResolvedPublicPRODUCTION ERROR

Description

Error

App version: 1.0.0.1231

message
Z[X(...)] is undefined

Impact

unknown

Notes

Details

Request ID
https://logstash.wikimedia.org/app/kibana#/doc/logstash-*/logstash-2020.09.10/clienterror?id=AXR41Zd5NoG2jwpwahJn&_g=h@44136fa
Request URL
n/a
Stack Trace
exception.trace
	getCategories@app://kaios.wikipedia.org/dist/main.js:1:37369
resolvedOptions@app://kaios.wikipedia.org/dist/main.js:1:39924
getPluralForm@app://kaios.wikipedia.org/dist/main.js:1:5717
convertPlural@app://kaios.wikipedia.org/dist/main.js:1:5593
plural@app://kaios.wikipedia.org/dist/main.js:1:18031
emit@app://kaios.wikipedia.org/dist/main.js:1:17702
h.exports</s/emit/I<@app://kaios.wikipedia.org/dist/main.js:1:17591
emit@app://kaios.wikipedia.org/dist/main.js:1:17573
parse@app://kaios.wikipedia.org/dist/main.js:1:18426
i18n@app://kaios.wikipedia.org/dist/main.js:1:19536
useI18n/<@app://kaios.wikipedia.org/dist/main.js:1:380244
ArticleLanguage@app://kaios.wikipedia.org/dist/main.js:1:314633
E@app://kaios.wikipedia.org/dist/main.js:1:268950
A@app://kaios.wikipedia.org/dist/main.js:1:266538
_/<@app://kaios.wikipedia.org/dist/main.js:1:262572
_@app://kaios.wikipedia.org/dist/main.js:1:262455

Event Timeline

SBisson created this task.Sep 10 2020, 7:58 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 10 2020, 7:58 PM
SBisson added a subscriber: santhosh.EditedSep 10 2020, 8:00 PM

@santhosh This error has happened on the KaiOS app in production but originates in the banana-i18n library. I saw it only once so it's not critical but we'll want to look into it. If you have any thoughts about what might be going on, do let us know.

SBisson moved this task from Backlog to Ready for Dev on the Inuka-Team (Kanban) board.
hueitan added a subscriber: hueitan.Oct 8 2020, 8:42 AM

getCategories comes from the library intl-pluralrules, and we use the version of 1.2.1 from banana, and version 1.3.0 already replace it with the native Intl

probably an upgrade of banana can avoid this error.

PR : https://github.com/wikimedia/wikipedia-kaios/pull/278

I can't reproduce the error, but this upgrade may avoid this error in the future.

hueitan claimed this task.Oct 8 2020, 9:07 AM
hueitan removed hueitan as the assignee of this task.Oct 12 2020, 8:36 AM
hueitan moved this task from Code Review to Ready for Dev on the Inuka-Team (Kanban) board.

Moving this back as it requires more testing after the banana-i18n update with the bug fixed.

hueitan claimed this task.Oct 22 2020, 1:13 PM
hueitan moved this task from Ready for Dev to Code Review on the Inuka-Team (Kanban) board.

update version of banana-i18n to 2.0.0, same pr.

SBisson moved this task from Code Review to QA on the Inuka-Team (Kanban) board.Oct 22 2020, 1:58 PM

The PR is merged

Jpita added a subscriber: Jpita.Nov 2 2020, 6:38 PM

I remember we had some issue with updating banana before, was it the popup preview one?

I remember we had some issue with updating banana before, was it the popup preview one?

The reference popup was broken with an earlier version of banana. It should be OK with this one.

Jpita moved this task from QA to Design sign off on the Inuka-Team (Kanban) board.Nov 2 2020, 8:57 PM
AMuigai closed this task as Resolved.Nov 5 2020, 12:26 PM