CodeReview's parsers suck
Open, LowPublic

Description

Both the parsers for commit messages and the code comments are broken in odd ways.

http://www.mediawiki.org/wiki/Special:Code/MediaWiki/16967#code-comments is a fairly good example of two issues.

This query...

mysql> select cc_text from code_comment where cc_rev_id = 16967\G

  • 1. row *******

cc_text: The line "if($vCode==$wgContLang->getCode()) continue; // we don't want default variant" doesn't work correctly on zhwiki (and other wikis with $wgLanguageCode = 'zh'), where the language code 'zh' is also used as a variant name (which means 'no conversion'; technically it's a variant). Omitting zh variant causes /zh/Page_Name urls (when $wgArticlePath = '/$2/$1') not to be purged.

  • 2. row *******

cc_text: Filed to bugzilla as [[bugzilla:24027|bug 24027]].

  • 3. row *******

cc_text: <nowiki>bug 24027</nowiki> will link to bugzilla :)
3 rows in set (0.02 sec)

... shows the raw text. The parser doesn't listen to <nowiki> and it doesn't properly expand interwiki links like "bugzilla:".

http://www.mediawiki.org/wiki/Special:Code/MediaWiki/67090 demonstrates a problem with the commit message parser. The raw text is "The reason for this change is given in http://lists.wikimedia.org/pipermail/wikitech-l/2010-April/047617.html." However the trailing ">" is turned into &gt; inexplicably.

Some parser tests (or a change in the overall implementation of CodeReview's message parsing) would be good.


Version: unspecified
Severity: normal

Details

Reference
bz24279
bzimport raised the priority of this task from to Low.
bzimport set Reference to bz24279.
bzimport added a subscriber: Unknown Object (MLST).
MZMcBride created this task.Jul 6 2010, 4:00 AM

I guess the Code Review parser is not really parsing something. It simply replaces every "bug 12345" with "[https://bugzilla.wikimedia.org/show_bug.cgi?id=12345 bug 12345]" and sends the replaced text to normal MediaWiki parser. In this way, this bug appears.

Another example at http://www.mediawiki.org/wiki/Special:Code/MediaWiki/63214#c7615

The text "bug 13518#c9" doesn't include the section anchor as it should.

and bug 13518 comment 9 does not work either.

This is related to bug 21239.

Reedy added a comment.Jul 20 2010, 6:37 PM

(In reply to comment #3)

and bug 13518 comment 9 does not work either.

That seems to... It's linked

(In reply to comment #5)

(In reply to comment #3)
> and bug 13518 comment 9 does not work either.

That seems to... It's linked

It's not linked to the comment specified.

Ignore me

MaxSem has started some parser tests under r69611

  • Bug 27371 has been marked as a duplicate of this bug. ***