Page MenuHomePhabricator

FlaggedRevs doesn't check the 'neverBlocked' / APCOND_FR_NEVERBLOCKED option when autopromoting
Closed, ResolvedPublic

Description

FlaggedRevs doesn't check the 'neverBlocked' / APCOND_FR_NEVERBLOCKED option when autopromoting.

Autopromotion has been broken for a long time, and after fixing it in T237191, I discovered that all of the promoted users have been blocked before, opposite of what is supposed to happen.

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 15 2020, 7:39 PM
DannyS712 added a subscriber: DannyS712.
Restricted Application added a project: User-DannyS712. · View Herald TranscriptSep 15 2020, 7:42 PM

Checking the last 100 promoted users on de.wp:

Script that generated this table:

UsernamePromotedBlocked
Benutzer:Pacogo72020-09-15T19:29:58Z2010-08-23T15:29:13Z
Benutzer:Porrohman2020-09-15T18:17:13Z2011-12-21T01:09:49Z
Benutzer:Xquenda2020-09-15T18:07:21Z2017-09-16T10:09:52Z
Benutzer:Koenraad2020-09-15T17:51:16Z2015-12-10T18:52:13Z
Benutzer:Nasiruddin2020-09-15T17:24:30Z2020-03-24T11:15:05Z
Benutzer:Pass34562020-09-15T17:17:51Z2018-05-26T09:21:23Z
Benutzer:Oalexander2020-09-15T17:10:59Z2008-02-25T16:20:13Z
Benutzer:LSE Wendland2020-09-15T17:06:44Z2019-03-28T06:29:30Z
Benutzer:Chemiewikibm2020-09-15T16:46:13Z2010-11-06T16:00:51Z
Benutzer:The real Marcoman2020-09-15T16:38:59Z2009-01-01T11:21:53Z
Benutzerin:Alberich212020-09-15T16:36:10Z2009-05-03T11:07:26Z
Benutzer:Tri-l2020-09-15T15:58:26Z2013-07-22T16:05:36Z
Benutzer:Carbidfischer2020-09-15T15:52:53Z2009-04-28T05:17:02Z
Benutzer:Andreas Werle2020-09-15T15:24:56Z2008-03-17T20:24:07Z
Benutzer:Mitulski2020-09-15T15:04:39Z2020-06-25T21:54:18Z
Benutzer:Klaus Frisch2020-09-15T11:50:26Z2020-05-10T23:29:23Z
Benutzer:Tommes2020-09-15T11:27:31Z2016-12-21T14:42:05Z
Benutzer:Juliabackhausen2020-09-15T11:10:50Z2008-04-17T19:46:00Z
Benutzer:Mirmok122020-09-15T11:09:17Z2020-06-15T15:46:02Z
Benutzer:Eschenmoser2020-09-15T10:43:06Z2009-12-13T17:48:24Z
Benutzer:Erichsohn2020-09-15T10:30:24Z2020-08-11T06:31:51Z
Benutzer:Denis Barthel2020-09-15T10:18:42Z2007-01-20T23:48:11Z
Benutzer:DestinyFound2020-09-15T09:50:29Z2018-11-01T01:09:02Z
Benutzer:Maikel2020-09-15T09:36:43Z2007-03-08T22:08:40Z
Benutzer:Ivsoli2020-09-15T08:34:19Z2019-12-15T14:23:32Z
Benutzer:Q-ß2020-09-15T08:23:39Z2017-06-09T09:22:52Z
Benutzer:Brutarchitekt2020-09-15T08:20:56Z2019-08-13T04:27:09Z
Benutzer:Karl Friedrich Lindenau2020-09-15T07:48:00Z2019-02-11T13:42:55Z
Benutzer:Thenardier2020-09-15T07:00:38Z2013-02-08T19:28:37Z
Benutzer:ChrisHardy2020-09-15T06:31:23Z2014-11-03T13:46:48Z
Benutzer:ﺀ2020-09-15T06:27:12Z2017-12-18T08:48:30Z
Benutzer:Pingsjong2020-09-15T05:55:13Z2018-06-18T19:45:59Z
Benutzer:Cοlin2020-09-15T04:48:39Z2013-06-20T20:44:03Z
Benutzer:Legatorix2020-09-15T04:33:10Z2020-06-26T13:02:54Z
Benutzer:HSV4ever2020-09-15T04:22:31Z2019-06-20T10:05:15Z
Benutzer:Ot2020-09-15T03:39:03Z2009-12-19T16:29:19Z
Benutzer:Ulamm2020-09-14T23:57:12Z2018-08-28T20:15:27Z
Benutzer:Xerxes9312020-09-14T23:18:55Z2019-11-17T11:33:42Z
Benutzer:Kim1172020-09-14T22:54:47Z2016-01-16T21:46:08Z
Benutzerin:IntelTesla2020-09-14T22:51:17Z2020-09-04T11:43:47Z
Benutzer:Nassauer272020-09-14T22:19:08Z2007-12-29T17:36:20Z
Benutzer:Drawback2020-09-14T21:56:36Z2017-04-22T10:06:18Z
Benutzer:DerHexer2020-09-14T21:53:09Z2012-08-27T10:54:30Z
Benutzer:Odeesi2020-09-14T21:35:47Z2011-06-24T09:33:55Z
Benutzer:César2020-09-14T21:20:39Z2007-04-22T20:53:19Z
Benutzer:Amtiss2020-09-14T20:53:14Z2020-06-26T13:03:50Z
Benutzer:MBxd12020-09-14T20:40:55Z2013-06-06T21:05:43Z
Benutzer:Regi512020-09-14T20:40:15Z2008-09-23T08:44:38Z
Benutzer:Stephan Klage2020-09-14T20:39:12Z2020-05-09T11:36:43Z
Benutzer:Wilkibur2020-09-14T19:59:45Z2013-06-01T23:00:38Z
Benutzer:Christine R. Auer2020-09-14T19:39:42Z2014-06-07T20:07:20Z
Benutzer:AHZ2020-09-14T19:31:53Z2007-06-20T19:12:12Z
Benutzer:Superbass2020-09-14T19:16:50Z2007-01-29T21:07:36Z
Benutzer:Paddy2020-09-14T19:14:25Z2016-02-18T15:54:22Z
Benutzer:Perrak2020-09-14T19:08:23Z2007-01-04T15:31:13Z
Benutzer:Kein Einstein2020-09-14T19:05:36Z2011-06-01T17:29:31Z
Benutzer:Xqbot2020-09-14T18:55:17Z2020-03-22T16:19:36Z
Benutzer:FelMol2020-09-14T18:52:12Z2012-06-09T19:07:47Z
Benutzer:Hg69962020-09-14T18:42:18Z2011-03-25T21:31:37Z
Benutzer:Antonsusi2020-09-14T18:39:21Z2010-05-21T12:43:51Z
Benutzer:Chtrede2020-09-14T18:22:24Z2018-10-17T14:57:51Z
Benutzer:Tmid2020-09-14T18:19:25Z2011-03-26T16:55:11Z
Benutzer:Vhorvat2019-06-24T22:45:18Z-
Benutzer:Neutronstar22019-06-24T22:19:56Z-
Benutzer:Labintatlo2019-06-24T22:03:22Z-
Benutzer:Der Wärschtlamo2019-06-24T21:35:40Z-
Benutzer:Sneeuwschaap2019-06-24T20:06:30Z-
Benutzer:Wernerdechent2019-06-24T18:30:49Z-
Benutzer:Rio.Negro2019-06-24T18:11:17Z-
Benutzer:Dein Deutschlehrer2019-06-24T15:08:22Z-
Benutzer:Ozeanya2019-06-24T14:09:42Z-
Benutzer:Epitheton2019-06-24T13:55:57Z-
Benutzer:MMunke2019-06-24T09:50:04Z-
Benutzer:GrFue2019-06-24T08:12:59Z-
Benutzer:Heiner072019-06-23T18:13:37Z-
Benutzer:Pockensupperl2019-06-23T17:17:40Z-
Benutzer:Schreckgespenst2019-06-23T15:01:53Z-
Benutzer:Hajime1232019-06-23T14:39:58Z-
Benutzer:Infopointaudim2019-06-23T10:24:59Z-
Benutzer:Crazypio2019-06-23T10:18:38Z-
Benutzer:Clash crafter2019-06-22T21:23:00Z-
Benutzer:Texvc2LaTeXBot2019-06-22T15:17:33Z-
Benutzer:Bild-Sprache2019-06-22T13:32:14Z-
Benutzer:Zamirax2019-06-22T11:15:10Z-
Benutzer:Weltseher2019-06-22T07:18:33Z-
Benutzer:Dante aurelius2019-06-21T19:47:48Z-
Benutzer:Yeah .0.52019-06-21T15:46:12Z-
Benutzerin:Baekemm2019-06-21T07:35:53Z-
Benutzer:Juniperi2019-06-21T07:26:53Z-
Benutzer:Panam20142019-06-21T06:27:46Z-
Benutzer:Eberhard Schmiedel2019-06-21T05:39:53Z-
Benutzer:Agentur 2562019-06-21T05:32:58Z-
Benutzer:Aljona Makarowa2019-06-21T03:58:03Z-
Benutzer:Kigutarnak2019-06-20T21:31:48Z-
Benutzer:GregTCLTK2019-06-20T21:11:17Z-
Benutzer:Madri192019-06-20T19:20:28Z-
Benutzer:CengizHanAltai2019-06-20T19:06:06Z-
Benutzer:Altair 782019-06-20T17:29:27Z-
Benutzer:DierkA2019-06-20T11:27:30Z-
Benutzer:Prof. des.2019-06-20T09:00:18Z-

Change 627456 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/extensions/FlaggedRevs@master] Fix APCOND_FR_NEVERBLOCKED handling

https://gerrit.wikimedia.org/r/627456

Udo_T added a subscriber: Udo_T.Sep 15 2020, 7:54 PM

Will need to be backported to 1.34 and 1.35 once merged

So to clarify, the problem is actually not that it "doesn't check" it, but rather it checks it and returns the opposite result?

So to clarify, the problem is actually not that it "doesn't check" it, but rather it checks it and returns the opposite result?

Yes, that appears to be the case

Change 627456 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@master] Fix APCOND_FR_NEVERBLOCKED handling

https://gerrit.wikimedia.org/r/627456

Change 627457 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/extensions/FlaggedRevs@REL1_35] Fix APCOND_FR_NEVERBLOCKED handling

https://gerrit.wikimedia.org/r/627457

Change 627458 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/extensions/FlaggedRevs@REL1_34] Fix APCOND_FR_NEVERBLOCKED handling

https://gerrit.wikimedia.org/r/627458

I +2'ed the cherry picks for 1.34 and 1.35. Given how long this has been an issue, I don't think it warrants cherry picking to the currently deployed version, and can wait for the train next week, but I'll leave that up to @matmarex

Change 627457 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@REL1_35] Fix APCOND_FR_NEVERBLOCKED handling

https://gerrit.wikimedia.org/r/627457

Change 627458 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@REL1_34] Fix APCOND_FR_NEVERBLOCKED handling

https://gerrit.wikimedia.org/r/627458

matmarex added a comment.EditedSep 15 2020, 8:25 PM

I +2'ed the cherry picks for 1.34 and 1.35. Given how long this has been an issue, I don't think it warrants cherry picking to the currently deployed version, and can wait for the train next week, but I'll leave that up to @matmarex

So, the bug was introduced in that commit from 24 September 2019, but the code was not actually used at the time due to a bug in our configuration (T237191: FlaggedRevs: Automatic user promotion stopped working on some wikis on June 24, 2019), until I fixed that configuration yesterday. I'll do the backports later today.

Change 627461 had a related patch set uploaded (by Bartosz Dziewoński; owner: DannyS712):
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.8] Fix APCOND_FR_NEVERBLOCKED handling

https://gerrit.wikimedia.org/r/627461

Change 627462 had a related patch set uploaded (by Bartosz Dziewoński; owner: DannyS712):
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.9] Fix APCOND_FR_NEVERBLOCKED handling

https://gerrit.wikimedia.org/r/627462

Wargo added a subscriber: Wargo.Sep 15 2020, 8:46 PM

Change 627461 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.8] Fix APCOND_FR_NEVERBLOCKED handling

https://gerrit.wikimedia.org/r/627461

Change 627462 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.9] Fix APCOND_FR_NEVERBLOCKED handling

https://gerrit.wikimedia.org/r/627462

Mentioned in SAL (#wikimedia-operations) [2020-09-15T23:18:42Z] <urbanecm@deploy1001> Synchronized php-1.36.0-wmf.8/extensions/FlaggedRevs/backend/FlaggedRevsHooks.php: 5beace32a396adfcce46b04e7f969b2f9f9effda: Fix APCOND_FR_NEVERBLOCKED handling (T262970) (duration: 00m 58s)

Mentioned in SAL (#wikimedia-operations) [2020-09-15T23:20:33Z] <urbanecm@deploy1001> Synchronized php-1.36.0-wmf.9/extensions/FlaggedRevs/backend/FlaggedRevsHooks.php: 1c0b0d161fe1024d6d08a27bbacf5b62c56c9c01: Fix APCOND_FR_NEVERBLOCKED handling (T262970) (duration: 00m 56s)

matmarex closed this task as Resolved.Sep 15 2020, 11:27 PM

Should be fixed by @DannyS712's patch, which is now deployed to all Wikimedia wikis.

@matmarex, @DannyS712 Hmm, weirdly enough at least two users one dewiki automatically got autoreview rights today despite having been blocked before:

I haven't gone through the whole list but something still seems amiss.

DannyS712 reopened this task as Open.EditedSep 16 2020, 8:55 PM

@matmarex, @DannyS712 Hmm, weirdly enough at least two users one dewiki automatically got autoreview rights today despite having been blocked before:

I haven't gone through the whole list but something still seems amiss.

I think the issue is that these values are cached (for a week if I'm ready it correctly) - @matmarex could that be causing this?

They are cached, but in your patch you added the negation "outside" the cache, so that shouldn't be the problem. Unless there's some other incorrect logic in there.

DannyS712 added a subscriber: Urbanecm.EditedSep 16 2020, 10:45 PM

They are cached, but in your patch you added the negation "outside" the cache, so that shouldn't be the problem. Unless there's some other incorrect logic in there.

@Urbanecm ran echo 'var_export( $wgAutopromoteOnce['onEdit'] );' | mwscript eval.php --wiki=dewiki | phaste to see what the actual criteria applied at run time is, and the result at P12614 shows that the APCOND_FR_NEVERBLOCKED is indeed being applied to autoreviewers.

I tested the condition manually on the beta cluster, and it correctly returns true for DannyS712:

> $u = User::newFromName( 'DannyS712' );

> $res = null;

> Hooks::runner()->onAutopromoteCondition( 70822, [], $u, $res );

> var_dump( $res );
bool(true)

But, when I found an account that has not been blocked, it still returned true - tested with DannyS712 test and the most recent account created on the beta cluster, MaryjoStrangways:

> $u = User::newFromName( 'DannyS712 test' );

> $res = null;

> Hooks::runner()->onAutopromoteCondition( 70822, [], $u, $res );

> var_dump( $res );
bool(true)

> $u = User::newFromName( 'MaryjoStrangways' );

> $res = null;

> Hooks::runner()->onAutopromoteCondition( 70822, [], $u, $res );

> var_dump( $res );
bool(true)

So it seems that regardless of if a user has been blocked before, the result is true.

Investigating further, I confirmed that the internal FlaggedRevsHooks::wasPreviouslyBlocked method should be working when the $cutoff_unixtime is the default 0

> echo( (int)Wikimedia\TestingAccessWrapper::newFromClass( FlaggedRevsHooks::class )->wasPreviouslyBlocked( User::newFromName( 'DannyS712' ), wfGetDB( DB_REPLICA ) ) );
1
> echo( (int)Wikimedia\TestingAccessWrapper::newFromClass( FlaggedRevsHooks::class )->wasPreviouslyBlocked( User::newFromName( 'DannyS712 test' ), wfGetDB( DB_REPLICA ) ) );
0

The relevant code:

$hasPriorBlock = (bool)$cache->getWithSetCallback(
	$cache->makeKey( 'flaggedrevs-autopromote-notblocked', $user->getId() ),
	$cache::TTL_SECOND,
	function ( $oldValue, &$ttl, array &$setOpts, $oldAsOf ) use ( $user ) {
		$dbr = wfGetDB( DB_REPLICA );
		$setOpts += Database::getCacheSetOptions( $dbr );
		return self::wasPreviouslyBlocked( $user, $dbr, $oldAsOf ?: 0 );
	},
	[ 'staleTTL' => $cache::TTL_WEEK ]
);
$result = !$hasPriorBlock;

passes the timestamp of the cached value, however. This means that the code only looks for blocks made since the last time it was checked. I suspect this was added so that once the cached value was that the user had a prior block, further checks would just return true, and if it was cached that they had no prior block, it would actually check the log to see if that had changed. This was the case prior to rEFLRd97307825e148c735427ab6808b351249216bc96

$key = wfMemcKey( 'flaggedrevs', 'autopromote-notblocked', $user->getId() );
$val = $wgMemc->get( $key );
if ( $val === 'false' ) {
	$result = false; // failed
} else {
	# Hit the DB if the result is not cached or if we need
	# to check if the user was blocked since the last check...
	$now_unix = time();
	$last_checked = is_int( $val ) ? $val : 0; // TS_UNIX
	$result = !self::wasPreviouslyBlocked( $user, $last_checked );
	$wgMemc->set( $key, $result ? $now_unix : 'false', 7 * 86400 );
}

Check the log, and if the user was previously blocked, say false, otherwise store the time of the latest check.
I'll sent a patch to restore this functionality, but the cached values may need to be cleared to ensure that there isn't pollution

Change 627803 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/extensions/FlaggedRevs@master] Fix APCOND_FR_NEVERBLOCKED handling (part 2)

https://gerrit.wikimedia.org/r/627803

I was just writing my own comment when you were writing yours… my understanding is:

(hopefully this is the same as yours, but less detailed, heh)

The negation should be inside, because:

  • The value 'false' can't be cached, only 'true'
  • When an outdated cached value is found, the code only checks the block log since the last time it was cached

As a result, if we cache 'true' for "the user has been blocked", the next time only recent block log will be checked, and (probably) no recent block will be found.

We must cache "true" for "the user has not been blocked", and then when only recent block log will be checked, the result will be correct.

@matmarex since the cache is only TTL_SECOND, I think its unlikely that cache pollution will be a problem. I've upload a patch to restore the old behavior and left detailed comments regarding how it worked

It has 'staleTTL' => $cache::TTL_WEEK though, so older values may be used somehow, I'm not sure if that matters.

I would just change the cache key to avoid messing with invalidation.

It has 'staleTTL' => $cache::TTL_WEEK though, so older values may be used somehow, I'm not sure if that matters.

I would just change the cache key to avoid messing with invalidation.

Current cached values are only true and false, which should all be ignored - not === 'priorBlock' and fails is_int if I understand correctly

Change 627803 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@master] Fix APCOND_FR_NEVERBLOCKED handling (part 2)

https://gerrit.wikimedia.org/r/627803

Change 627805 had a related patch set uploaded (by Bartosz Dziewoński; owner: DannyS712):
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.8] Fix APCOND_FR_NEVERBLOCKED handling (part 2)

https://gerrit.wikimedia.org/r/627805

Change 627947 had a related patch set uploaded (by Bartosz Dziewoński; owner: DannyS712):
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.9] Fix APCOND_FR_NEVERBLOCKED handling (part 2)

https://gerrit.wikimedia.org/r/627947

Change 627805 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.8] Fix APCOND_FR_NEVERBLOCKED handling (part 2)

https://gerrit.wikimedia.org/r/627805

Change 627947 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.9] Fix APCOND_FR_NEVERBLOCKED handling (part 2)

https://gerrit.wikimedia.org/r/627947

Mentioned in SAL (#wikimedia-operations) [2020-09-16T23:40:02Z] <catrope@deploy1001> Synchronized php-1.36.0-wmf.9/extensions/FlaggedRevs: T262970 (duration: 01m 06s)

Mentioned in SAL (#wikimedia-operations) [2020-09-16T23:41:08Z] <catrope@deploy1001> Synchronized php-1.36.0-wmf.8/extensions/FlaggedRevs: T262970 (duration: 01m 06s)

Change 627948 had a related patch set uploaded (by Bartosz Dziewoński; owner: DannyS712):
[mediawiki/extensions/FlaggedRevs@REL1_34] Fix APCOND_FR_NEVERBLOCKED handling (part 2)

https://gerrit.wikimedia.org/r/627948

Change 627949 had a related patch set uploaded (by Bartosz Dziewoński; owner: DannyS712):
[mediawiki/extensions/FlaggedRevs@REL1_35] Fix APCOND_FR_NEVERBLOCKED handling (part 2)

https://gerrit.wikimedia.org/r/627949

Change 627948 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@REL1_34] Fix APCOND_FR_NEVERBLOCKED handling (part 2)

https://gerrit.wikimedia.org/r/627948

Change 627949 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@REL1_35] Fix APCOND_FR_NEVERBLOCKED handling (part 2)

https://gerrit.wikimedia.org/r/627949

matmarex closed this task as Resolved.Sep 16 2020, 11:54 PM

Should be fixed for real this time… @Count_Count Thank you for checking it!

Also, for reference, here's the list of recently autopromoted users and whether any of them were blocked. Looks like the second problem only affected users on de.wp.


de.wikipedia.org

UsernamePromotedBlocked
Benutzer:BaseEvoli2020-09-16T22:31:22Z-
Benutzer:Rued-Di2020-09-16T22:05:38Z-
Benutzerin:KAMfakten2020-09-16T22:05:21Z-
Benutzer:Stb-le2020-09-16T22:01:25Z-
Benutzer:Blootwoosch2020-09-16T21:47:20Z2008-12-18T18:02:07Z
Benutzer:Mickey22020-09-16T21:41:17Z-
Benutzerin:Bücherwurm Susanne2020-09-16T21:32:09Z-
Benutzer:LucySky2020-09-16T21:24:43Z-
Benutzer:Cerxu2020-09-16T20:59:54Z-
Benutzer:Pan Tau2020-09-16T20:31:06Z2018-02-05T18:14:22Z
Benutzer:Wikigru1112020-09-16T20:19:02Z-
Benutzer:Volker Höhfeld2020-09-16T19:49:18Z-
Benutzer:Adierks2020-09-16T19:02:37Z-
Benutzerin:Annetee2020-09-16T19:00:04Z-
Benutzer:Wikiseidank2020-09-16T18:36:09Z-
Benutzer:FridoNarg2020-09-16T17:55:11Z-
Benutzer:Tintenherz122020-09-16T17:43:15Z2007-07-05T19:54:46Z
Benutzer:Hubert Durchdiewand2020-09-16T17:22:07Z-
Benutzer:Marnfred Klein2020-09-16T16:58:37Z-
Benutzer:DerTagesschauer2020-09-16T16:16:39Z-
Benutzer:Matthias Winkelmann2020-09-16T16:16:04Z-
Benutzer:Cartoffel2020-09-16T16:03:54Z-
Benutzer:Jinola2020-09-16T15:54:59Z-
Benutzer:FrancisMortain2020-09-16T15:54:51Z-
Benutzerin:Jucos2020-09-16T15:19:27Z2020-07-17T19:46:48Z
Benutzer:Philomar2020-09-16T15:03:06Z-
Benutzer:B wie Büchse22020-09-16T14:55:00Z-
Benutzer:Rkendlbacher2020-09-16T14:26:51Z-
Benutzerin:Praxidicae2020-09-16T14:08:25Z-
Benutzer:Darealclub2020-09-16T14:01:21Z2009-02-15T18:54:30Z
Benutzer:Bhuck2020-09-16T13:34:02Z2007-11-14T12:41:24Z
Benutzer:ASternberg2020-09-16T13:20:52Z-
Benutzer:Asmen2020-09-16T13:14:36Z2008-12-10T01:01:17Z
Benutzer:Queen of Fate2020-09-16T13:08:42Z-
Benutzer:Freundlicher Friese2020-09-16T13:06:33Z-
Benutzer:Erastophanes2020-09-16T13:03:35Z-
Benutzer:Spreevogel2020-09-16T12:53:37Z-
Benutzer:Manfred Werner (WMAT)2020-09-16T12:52:27Z-
Benutzer:Quintus Rufus2020-09-16T12:42:50Z-
Benutzer:Publikkom2020-09-16T12:40:08Z2017-06-03T08:56:57Z
Benutzer:Fryktlose skimml2020-09-16T12:24:20Z-
Benutzer:SweJoFu2020-09-16T12:05:50Z-
Benutzer:Accelerator19552020-09-16T11:30:48Z-
Benutzer:Ostseebaer2020-09-16T11:01:29Z-
Benutzer:Aroner1232020-09-16T10:46:56Z-
Benutzer:Anahuatl2020-09-16T10:41:15Z-
Benutzer:Reingeher2020-09-16T10:40:11Z-
Benutzer:Darkraid12020-09-16T10:25:14Z-
Benutzer:Dr. Markus Lepper2020-09-16T10:22:23Z-
Benutzer:Isidor Welti2020-09-16T10:17:21Z-
Benutzerin:Kajo20192020-09-16T10:09:02Z-
Benutzer:Tickle me2020-09-16T10:04:59Z2007-08-09T13:58:41Z
Benutzer:Renatoorsini2020-09-16T10:04:49Z-
Benutzer:Hajo.thelen2020-09-16T09:56:16Z-
Benutzerin:Ms. Politics2020-09-16T09:46:48Z-
Benutzer:Minzoblate2020-09-16T08:53:30Z-
Benutzer:Augustgeyler2020-09-16T08:47:56Z-
Benutzer:7lima2020-09-16T08:41:36Z-
Benutzer:Heinz Huster2020-09-16T08:26:31Z-
Benutzer:PantherStrix2020-09-16T08:15:28Z-
Benutzer:Naronnas2020-09-16T07:29:22Z-
Benutzer:RRST932020-09-16T07:21:09Z-
Benutzer:CountCountBot2020-09-16T07:18:21Z-
Benutzer:Sordmut2020-09-16T07:06:11Z-
Benutzer:Opensourcewarrior2020-09-16T06:58:41Z-
Benutzer:Cromono2020-09-16T06:46:09Z-
Benutzer:JanJan Hoff2020-09-16T06:07:18Z-
Benutzer:Systemling2020-09-16T05:34:54Z-
Benutzer:Eliheld2020-09-16T04:09:07Z-
Benutzer:Cabanero422020-09-16T03:03:02Z-
Benutzer:Macucal2020-09-16T01:16:55Z-
Benutzer:Faktengebunden2020-09-15T23:27:52Z-
Benutzer:Huku152020-09-15T23:25:04Z-
Benutzer:MicBy672020-09-15T23:10:41Z2020-06-07T07:12:20Z
Benutzer:Lumpeseggl2020-09-15T23:03:19Z2016-10-03T18:30:44Z
Benutzer:Nordostsüdwest2020-09-15T21:56:21Z2019-11-28T16:35:37Z
Benutzer:Magipulus2020-09-15T21:24:27Z2008-02-19T15:24:47Z
Benutzer:Robbit2020-09-15T21:00:19Z2007-02-08T08:30:22Z
Benutzer:M.ottenbruch2020-09-15T20:46:27Z2010-02-06T23:52:01Z
Benutzer:Noclador2020-09-15T20:32:38Z2007-06-08T17:13:41Z
Benutzer:Keichwa2020-09-15T20:15:18Z2005-06-26T14:42:45Z
Benutzer:Justus Nussbaum2020-09-15T20:11:08Z2008-09-22T11:00:47Z
Benutzer:Kuszel2020-09-15T19:56:06Z2020-06-16T21:43:21Z
Benutzer:Pacogo72020-09-15T19:29:58Z2010-08-23T15:29:13Z
Benutzer:Porrohman2020-09-15T18:17:13Z2011-12-21T01:09:49Z
Benutzer:Xquenda2020-09-15T18:07:21Z2017-09-16T10:09:52Z
Benutzer:Koenraad2020-09-15T17:51:16Z2015-12-10T18:52:13Z
Benutzer:Nasiruddin2020-09-15T17:24:30Z2020-03-24T11:15:05Z
Benutzer:Pass34562020-09-15T17:17:51Z2018-05-26T09:21:23Z
Benutzer:Oalexander2020-09-15T17:10:59Z2008-02-25T16:20:13Z
Benutzer:LSE Wendland2020-09-15T17:06:44Z2019-03-28T06:29:30Z
Benutzer:Chemiewikibm2020-09-15T16:46:13Z2010-11-06T16:00:51Z
Benutzer:The real Marcoman2020-09-15T16:38:59Z2009-01-01T11:21:53Z
Benutzerin:Alberich212020-09-15T16:36:10Z2009-05-03T11:07:26Z
Benutzer:Tri-l2020-09-15T15:58:26Z2013-07-22T16:05:36Z
Benutzer:Carbidfischer2020-09-15T15:52:53Z2009-04-28T05:17:02Z
Benutzer:Andreas Werle2020-09-15T15:24:56Z2008-03-17T20:24:07Z
Benutzer:Mitulski2020-09-15T15:04:39Z2020-06-25T21:54:18Z
Benutzer:Klaus Frisch2020-09-15T11:50:26Z2020-05-10T23:29:23Z
Benutzer:Tommes2020-09-15T11:27:31Z2016-12-21T14:42:05Z

de.wiktionary.org

UsernamePromotedBlocked
Benutzer:Roland Wingerter2020-09-15T23:28:25Z-
Benutzer:Wegner82020-09-15T08:37:57Z2009-02-16T23:31:11Z
Benutzer:Pametzma2020-09-14T19:42:10Z2012-07-06T08:07:23Z

en.wikibooks.org

UsernamePromotedBlocked
User:1234qwer1234qwer42020-09-16T22:49:36Z-
User:Goulart2020-09-16T10:00:58Z-
User:Chapka2020-09-16T07:42:03Z-

he.wikisource.org

UsernamePromotedBlocked
משתמש:Shahar92612020-09-16T04:41:17Z-

pl.wikipedia.org

UsernamePromotedBlocked
Wikipedysta:ZajeliWszystkieNicki2020-09-16T19:06:04Z-
Wikipedysta:YazJazz2020-09-16T16:04:16Z-
Wikipedysta:Grisha122020-09-16T09:01:35Z-
Wikipedysta:Mateusz Gieryga2020-09-15T21:34:22Z2020-07-12T16:36:37Z
Wikipedysta:Lukasz22020-09-15T18:01:25Z2018-10-30T09:18:51Z
Wikipedysta:Temuera2020-09-14T21:17:30Z2016-09-08T11:13:34Z

ru.wikisource.org

UsernamePromotedBlocked
Участник:Philip J.-wsx2020-09-16T17:54:05Z-
Участник:Dmitry V A2020-09-16T15:05:44Z-
Участник:KartaBY2020-09-16T11:23:08Z-
Участник:Kuzzim2020-09-16T11:22:20Z-
Участник:Wlbw682020-09-16T10:56:44Z-

sq.wikipedia.org

UsernamePromotedBlocked
Përdoruesi:Adhurim Jakupi2020-09-16T14:33:13Z-
Përdoruesi:Qendrimi152020-09-16T01:24:20Z-
Përdoruesi:InternetArchiveBot2020-09-16T00:50:04Z-

Was the cache cleared? Here is the next account which was autopromoted despite being blocked:

Was the cache cleared? Here is the next account which was autopromoted despite being blocked:

No idea why, sorry. @matmarex thoughts?

matmarex reopened this task as Open.Sep 17 2020, 8:04 PM

Argh, we inverted the condition again…

Change 628189 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/FlaggedRevs@master] Fix APCOND_FR_NEVERBLOCKED handling (part 3)

https://gerrit.wikimedia.org/r/628189

Change 628206 had a related patch set uploaded (by Urbanecm; owner: Bartosz Dziewoński):
[mediawiki/extensions/FlaggedRevs@REL1_35] Fix APCOND_FR_NEVERBLOCKED handling (part 3)

https://gerrit.wikimedia.org/r/628206

Change 628207 had a related patch set uploaded (by Urbanecm; owner: Bartosz Dziewoński):
[mediawiki/extensions/FlaggedRevs@REL1_34] Fix APCOND_FR_NEVERBLOCKED handling (part 3)

https://gerrit.wikimedia.org/r/628207

Change 628208 had a related patch set uploaded (by Urbanecm; owner: Bartosz Dziewoński):
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.9] Fix APCOND_FR_NEVERBLOCKED handling (part 3)

https://gerrit.wikimedia.org/r/628208

Change 628189 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@master] Fix APCOND_FR_NEVERBLOCKED handling (part 3)

https://gerrit.wikimedia.org/r/628189

Change 628206 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@REL1_35] Fix APCOND_FR_NEVERBLOCKED handling (part 3)

https://gerrit.wikimedia.org/r/628206

Change 628207 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@REL1_34] Fix APCOND_FR_NEVERBLOCKED handling (part 3)

https://gerrit.wikimedia.org/r/628207

Change 628208 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@wmf/1.36.0-wmf.9] Fix APCOND_FR_NEVERBLOCKED handling (part 3)

https://gerrit.wikimedia.org/r/628208

Mentioned in SAL (#wikimedia-operations) [2020-09-17T20:47:24Z] <urbanecm@deploy1001> Synchronized php-1.36.0-wmf.9/extensions/FlaggedRevs/backend/FlaggedRevsHooks.php: 19b9b9877ea3f8ffa6626108941891c2454348de: Fix APCOND_FR_NEVERBLOCKED handling (part 3; T262970) (duration: 00m 57s)

Urbanecm closed this task as Resolved.Sep 17 2020, 8:48 PM
Urbanecm triaged this task as High priority.

Tentatively closing again :).

List of affected users:
de.wikipedia.org

UsernamePromotedBlocked
Benutzer:Grenzdebiler2020-09-17T19:58:52Z2020-06-14T20:57:09Z
Benutzer:Henri5562020-09-17T18:40:35Z2020-05-24T09:12:42Z
Benutzer:Gc19432020-09-17T18:19:12Z2017-10-08T10:12:04Z
Benutzer:Hs-berlin2020-09-17T16:46:15Z2013-09-23T12:32:43Z
Benutzer:Rtc2020-09-17T16:21:02Z2013-09-29T07:39:36Z
Benutzer:HilmarHansWerner2020-09-17T16:18:54Z2018-04-28T21:41:59Z
Benutzer:RockDJ042020-09-17T14:39:55Z2009-07-22T06:51:15Z
Benutzer:ElNuevoEinstein2020-09-17T14:14:48Z2020-08-08T19:05:18Z
Benutzer:Snotty2020-09-17T13:22:26Z2006-11-03T17:36:21Z
Benutzer:Henriette Fiebig2020-09-17T11:46:35Z2008-01-18T08:04:36Z
Benutzer:Mo4jolo2020-09-17T10:59:46Z2009-01-26T15:03:59Z
Benutzer:Sebastian.Dietrich2020-09-17T09:58:23Z2009-07-08T17:22:48Z
Benutzer:Kattesmile22020-09-17T09:44:06Z2019-01-29T10:59:14Z
Benutzer:Agentjoerg2020-09-17T09:19:18Z2020-08-13T08:39:55Z
Benutzer:Venezianer2020-09-17T09:18:37Z2007-06-07T21:46:56Z
Benutzer:Dick Tracy2020-09-17T09:17:46Z2006-10-06T20:28:26Z
Benutzer:Hemeier2020-09-17T09:02:38Z2007-09-18T12:18:16Z
Benutzer:Edelseider2020-09-17T08:07:19Z2020-07-17T14:11:36Z
Benutzer:Tolanor2020-09-17T07:57:55Z2007-04-02T15:38:46Z
Benutzer:Qumranhöhle2020-09-17T07:36:50Z2016-08-25T10:45:49Z
Benutzer:Torbenbrinker2020-09-17T07:24:12Z2009-10-15T17:19:46Z
Benutzer:Vinojan2020-09-17T07:19:43Z2010-11-05T20:23:35Z
Benutzer:Vsler2020-09-17T05:02:16Z2019-08-27T18:14:09Z
Benutzer:Prüm2020-09-17T03:07:10Z2020-04-13T11:32:45Z

pl.wikipedia.org

UsernamePromotedBlocked
Wikipedysta:V.C.2020-09-17T06:34:29Z2008-07-09T20:25:09Z

@matmarex Looks good today, keeping my fingers crossed.

Interestingly enough the mildly annoying quirk that administrators and editors automatically get the autoreview right seems to have stopped as well (?)

@matmarex Should we inform admins somehow, or was that done?

@matmarex Should we inform admins somehow, or was that done?

We have it covered for dewiki.

@Urbanecm It was discussed in more detail on T237191 and folks posted notices or fixed the rights (@Count_Count did dewiki, and also @Udo_T did dewiktionary and I did plwiki).