Page MenuHomePhabricator

Post-merge build failed due to a PHP version issue
Open, Needs TriagePublic

Description

Patch: https://gerrit.wikimedia.org/r/c/mediawiki/extensions/AbuseFilter/+/627958
Jenkins post-merge build report: https://integration.wikimedia.org/ci/job/mwext-phpunit-coverage-docker-publish/28496/console

The specific issue: This package requires php >=7.3.19 but your PHP version (7.2.31) does not satisfy that requirement.

Requests: (1) please help fix this build issue; (2) please help merge this patch, which, due to the post-merge build failure, has not been merged.

Event Timeline

Huji created this task.Sep 17 2020, 4:36 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 17 2020, 4:36 PM

@Huji https://gerrit.wikimedia.org/r/c/mediawiki/extensions/AbuseFilter/+/627958 says it was merged, and post-merge builds failing doesn't prevent the merge itself

@DannyS712 then how come I don't see it at https://phabricator.wikimedia.org/diffusion/EABF/history/master/ ? Similarly, rEABFbcb5932a5ce8711ff134369f4d2c46208f272913 does not indicate it being merged (compare with rEABF12586812c2f42f21486dfa51bb17af5dccd19f56 for instance)

Because it was merged to 1.35, not master. rEABFbcb5932a5ce8711ff134369f4d2c46208f272913 shows Branches REL1_35

Huji added a comment.Sep 17 2020, 5:25 PM

Oh well. I need food :)