Page MenuHomePhabricator

Pageview and editing stats for Fundraising Report
Closed, ResolvedPublic

Description

The fundraising analytics team is working with the rest of the fundraising teams this quarter to put together our yearly fundraising report for FY1920. [here is last year's report for reference].

We are reaching out to you as we have two questions regarding stats that we'd highly appreciate your team's input on:

#1. In the opening paragraph of the report, we'd like to reference the number of edits made every second on Wikipedia, or another good metric that captures Wikipedia's growth in real time. Our fundraising copywriter used 1.9 edits per second, which was taken from this page, but I am not sure this is really the number we should be using, and I wouldn't want to send people to this static page. Could you please advise on what the best number would be to use here and include the source? Given that this report may generate some traffic, I want to be mindful of where we send people and see if there are any numbers that your team may want to highlight, from this page or somewhere else.

#2. In the last part of the opening paragraph, Sam Lien from comms suggested we add some pageview data, which I think could be a great idea. Do you have a recommendation for a number to highlight and the source?

I am really sorry to ask you for a quick turnaround on this, as I imagine you have a lot on your plate. That said, we are hoping to wrap up the edits in our doc by the end of the week, to move into the production phase of the report. Would you be able to have a look and advice on this before the end of the week you think?

Details

Due Date
Sep 25 2020, 7:00 PM

Event Timeline

kzimmerman triaged this task as High priority.Sep 23 2020, 12:13 AM
kzimmerman set Due Date to Sep 25 2020, 7:00 PM.

Commenting here because I'd be curious to know if we have other sources we'd use for this: For #1, using the edit counts for all Wikipedias on wikistats[1], it looks like we're pretty consistently in the 15–16M range now (I see March–May as COVID-related outliers). So I'd suggest August 2020 is a reasonable estimate for activity. With 15,927,411 edits in 31 days in August, and assuming the normal 86400 seconds/day, we get 5.95 edits per second to all Wikipedias.

Footnotes:
1: Here's the link because Phabricator doesn't like pipes in URLs and I'm too lazy to fix it: https://stats.wikimedia.org/#/all-wikipedia-projects/contributing/edits/normal|bar|2-year|~total|monthly

kzimmerman added a comment.EditedSep 23 2020, 10:56 PM

We recently confirmed year-end metrics for Finance's Annual Audit report (see T261781), and for consistency we'll use the same methodology here; mainly, that means using totals and averages from the FY19-20 Fiscal Year. As Jessica and @nettrom_WMF suggested, we'll use the metrics from Wikistats.

#1. Here is the link for Wikistats edits across all Wikipedias, filtered for FY19-20: https://stats.wikimedia.org/#/all-wikipedia-projects/contributing/edits/normal|bar|2019-07-01~2020-07-01|~total|daily
We had a total of 195 million edits over the course of the year (366 days in FY19-20 due to the leap year); with 86,400 seconds/day, that yields over 6 edits/second

NOTE: the number provided by the Fundraising copywriter using https://en.wikipedia.org/wiki/Wikipedia:Statistics only includes English Wikipedia. It looks like you want numbers across all Wikipedias, provided here.

#2. Speaking to overall pageviews and the number of languages might help convey the point about how our projects distribute reliable, fact-based information to people across the world. Here are the numbers we confirmed for Finance's Annual Audit report (T261781):

Wikipedia and the other projects operated by the Foundation received more than 16.7 billion page views per month, making them one of the most popular Web properties worldwide. Wikipedia is available in more than 303 languages and contains more than 54 million articles contributed by a global volunteer community.

Public Sources:
more than 16.7 billion page views per month: https://stats.wikimedia.org/#/all-projects/reading/total-page-views/normal|bar|2019-07-01~2020-07-01|agent~user|monthly (average for FY19-20 across all Wikis (Wikipedia + other projects), excludes automated and bot traffic)
303 languages: https://meta.wikimedia.org/wiki/List_of_Wikipedias (Wikipedia only; we count active Wikipedias)
54 million articles: https://stats.wikimedia.org/#/all-wikipedia-projects/content/pages-to-date/normal|line|2019-07-01~2020-07-01|page_type~content|monthly (Wikipedia only; for this number we take the content at the end of June, which was 54 million)

This is perfect! Thank you very much for your help @kzimmerman and team!

kzimmerman closed this task as Resolved.Sep 24 2020, 10:50 PM

You're welcome, @jrobell! Closing this as resolved.