Page MenuHomePhabricator

[wmf.10] mobile - mw-ge-small-task-card-pageviews skeleton persistently displayed in post-edit dialog
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  1. On mobile testwiki wmf.10 go to SE article and edit it.
  2. The post-edit dialog will display mw-ge-small-task-card-pageviews skeleton persistently

The issue is displayed in a browser emulator (Chrome browser) and on a real device - iPhone 6s (iOS 13.7)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 23 2020, 4:12 AM

Change 629255 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/extensions/GrowthExperiments@master] Fix GrowthTasksApi lazy-loading flags for pages with no views

https://gerrit.wikimedia.org/r/629255

Change 629256 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/extensions/GrowthExperiments@master] Mark pageviews as not used in the mobile postedit notice

https://gerrit.wikimedia.org/r/629256

Tgr edited projects, added Growth-Team (Current Sprint); removed Growth-Team.EditedSep 23 2020, 6:01 AM
Tgr moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

This will need to be backported tomorrow. Thanks for catching the bug!

Tgr claimed this task.Sep 23 2020, 6:18 AM

Change 629201 had a related patch set uploaded (by Kosta Harlan; owner: Gergő Tisza):
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.10] Mark pageviews as not used in the mobile postedit notice

https://gerrit.wikimedia.org/r/629201

Change 629202 had a related patch set uploaded (by Kosta Harlan; owner: Gergő Tisza):
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.10] Fix GrowthTasksApi lazy-loading flags for pages with no views

https://gerrit.wikimedia.org/r/629202

Change 629256 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Mark pageviews as not used in the mobile postedit notice

https://gerrit.wikimedia.org/r/629256

Change 629255 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Fix GrowthTasksApi lazy-loading flags for pages with no views

https://gerrit.wikimedia.org/r/629255

Change 629202 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.10] Fix GrowthTasksApi lazy-loading flags for pages with no views

https://gerrit.wikimedia.org/r/629202

Change 629201 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.10] Mark pageviews as not used in the mobile postedit notice

https://gerrit.wikimedia.org/r/629201

Backporting to wmf.10 at the moment.

Mentioned in SAL (#wikimedia-operations) [2020-09-23T11:49:26Z] <urbanecm@deploy1001> Synchronized php-1.36.0-wmf.10/extensions/GrowthExperiments/modules/help/ext.growthExperiments.PostEdit.js: 1ab31a966edc4748f82f75bb370371733c2ca090: Mark pageviews as not used in the mobile postedit notice (T263611) (duration: 01m 06s)

Mentioned in SAL (#wikimedia-operations) [2020-09-23T11:51:21Z] <urbanecm@deploy1001> Synchronized php-1.36.0-wmf.10/extensions/GrowthExperiments/modules/homepage/suggestededits/ext.growthExperiments.Homepage.GrowthTasksApi.js: 73b5ce82b3913232b708405147f0bb6d27128974: Fix GrowthTasksApi lazy-loading flags for pages with no views (T263611) (duration: 01m 05s)

Etonkovidova closed this task as Resolved.Sep 23 2020, 5:46 PM

Checked in testwiki wmf.10 - the issue is fixed.