Page MenuHomePhabricator

"The OTRS background task is not launched. Please contact your administrator" on OTRS web interface
Closed, InvalidPublic

Description

On https://ticket.wikimedia.org/otrs/index.pl?Action=AgentTicketZoom;TicketID=11521412 and other pages, I see in a red header bar following message:

The OTRS background task is not launched. Please contact your administrator

So here it is :) May be related to T187984: Update OTRS to the latest stable version (6.0.x)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 25 2020, 5:57 PM

Can't reproduce this. Navigating to that Ticket (or any other page for that matter) does not produce that bar. Furthermore, the otrs daemon (which is what that message refers to), is running just fine for 9 days now and during the timeperiod the task was created it was clearly doing this.

@Framawiki do you still see that bar?

I no longer see the message.

I can confirm it was the exact sentence in this localized message, corresponding to this check in the code.

@akosiaris Feel free to close this task if you think nothing can be done :)

akosiaris closed this task as Invalid.Sep 28 2020, 9:16 AM

I 'll do so, but feel free to to reopen if this reoccurs. In that case, please provide us with as much info as possible (e.g. timestamps, the page/article this shows up on, whether you have already forced refresh in the browser).

Got a similar message when looking at a Ticket just now. It went away when I locked the ticket.

And again, can't reproduce. Not only that, but logs around the time of the report indicate that the daemon was working fine. That is also supported by systemd's status for the service

Active: active (running) since Tue 2020-09-29 13:48:20 UTC; 1 weeks 5 days ago

I am thinking that this may be some small race condition between some timer in the the web app and the daemon and doesn't really affect anything.

Since we already got monitoring for the otrs daemon that would alert way of crashes way faster than agents and in the interest of not bugging agents about something that will fix itself in the next few seconds, I 've went ahead and set Frontend::NotifyModule###800-Daemon-Check to false.