Page MenuHomePhabricator

Special:MobileDiff no longer allows viewing deleted diffs because of wrong context title
Closed, ResolvedPublic

Description

Hello, I cannot see diff of this edit: https://cs.m.wikipedia.org/wiki/Speci%C3%A1ln%C3%AD:Mobiln%C3%AD_rozd%C3%ADl/19026136?diffmode=source from mobile phone. When I click here: https://cs.m.wikipedia.org/w/index.php?title=Diskuse_s_wikipedistou:Zbrnajsem&unhide=1, I cannot see diff. I see talk page of Zbrnajsem. And I am sysop of course.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 27 2020, 8:39 AM
Patriccck updated the task description. (Show Details)Sep 27 2020, 8:40 AM
Ammarpad added a subscriber: Ammarpad.

Caused by T245172/gerrit:625922 which changed context title to be the target title, hence why you're always being redirected to the talkpage

Ammarpad renamed this task from Cannot see a diff to Special:MobileDiff no longer allows viewing deleted diffs because of wrong context title.Sep 27 2020, 10:19 AM

Change 630389 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] Preserve query parameters when redirecting to mobile diff

https://gerrit.wikimedia.org/r/630389

Change 630390 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] Fix links to view mobile diffs of deleted revisions

https://gerrit.wikimedia.org/r/630390

Change 630389 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Preserve query parameters when redirecting to mobile diff

https://gerrit.wikimedia.org/r/630389

Change 630390 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Fix links to view mobile diffs of deleted revisions

https://gerrit.wikimedia.org/r/630390

Jdlrobson added a subscriber: Jdlrobson.

Will the editing team QA this?

@Jdlrobson What is QA? Question(s) (and) answer(s)?

Quality assurance - who will make sure we backport and verify the fix at WMF?

Much like T245172 (which caused this bug), this doesn't seem to be owned by any team, so I can just assure you that I tested it myself. I wasn't planning to backport the fix, since it's a relatively rarely used interface and you can still switch to desktop to access it.

I was going to just close this task, but looks like you want to own it. So, thanks.

@Jdlrobson I'm assuming you want me to recreate this in Beta. I added a discussion on a talk page, but I don't believe I have the permissions to delete it or the comment. I can only undo.

Jdlrobson closed this task as Resolved.Sep 30 2020, 5:21 PM

My team's not set up to test such changes, so we are going @Patriccck feel free to reopen this if the bug isn't fixed in this week's deployment. Provided all deploys go correctly this will be fixed on Thursday.