Page MenuHomePhabricator

Resolve Dashboard menu item
Closed, ResolvedPublic

Description

To do:

  • Modify user menu to include "My clients" (link to Special:AppManagement) in place of "Dashboard"
  • Modify the dashboard sidebar to include:
    • Dashboard (link to nothing, functions as a top-level category for these pages)
      • My clients (link to Special:AppManagement)
      • Notifications (link to Special:Notifications)
      • Preferences (link to Special:Preferences)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 30 2020, 9:26 PM
apaskulin triaged this task as High priority.Sep 30 2020, 9:32 PM
apaskulin claimed this task.Oct 5 2020, 7:08 PM

Assigning myself to the general task of figuring out how this should work in the portal

apaskulin renamed this task from Assign Dashboard menu item to Special:AppManagement to Resolve Dashboard menu item.Oct 6 2020, 5:39 PM
apaskulin updated the task description. (Show Details)

Change 632580 had a related patch set uploaded (by Alex Paskulin; owner: Alex Paskulin):
[mediawiki/skins/WikimediaApiPortal@master] copy: Update menu items for dashboard center

https://gerrit.wikimedia.org/r/632580

Change 632580 abandoned by Alex Paskulin:
[mediawiki/skins/WikimediaApiPortal@master] copy: Update menu items for dashboard center

Reason:
Abandoning in favor of two separate patches

https://gerrit.wikimedia.org/r/632580

Since the patch above conflicts with the refactor, I'll be waiting to re-open the patch for this fix until after the refactor is merged

apaskulin removed apaskulin as the assignee of this task.Oct 13 2020, 9:55 PM
apaskulin updated the task description. (Show Details)
apaskulin removed a project: Patch-For-Review.
apaskulin updated the task description. (Show Details)

Change 634081 had a related patch set uploaded (by Alex Paskulin; owner: Alex Paskulin):
[mediawiki/skins/WikimediaApiPortal@master] copy: Update dashboard in user menu

https://gerrit.wikimedia.org/r/634081

apaskulin updated the task description. (Show Details)

Change 634335 had a related patch set uploaded (by Cicalese; owner: Cicalese):
[mediawiki/skins/WikimediaApiPortal@master] Handle extra user menu and sidebar special pages.

https://gerrit.wikimedia.org/r/634335

Change 634081 abandoned by Alex Paskulin:
[mediawiki/skins/WikimediaApiPortal@master] copy: Update dashboard in user menu

Reason:
Abandoning in favor of 634335

https://gerrit.wikimedia.org/r/634081

Change 634356 had a related patch set uploaded (by Cicalese; owner: Cicalese):
[operations/mediawiki-config@master] Configuration for user menu and sidebar special pages.

https://gerrit.wikimedia.org/r/634356

Change 634543 had a related patch set uploaded (by Cicalese; owner: Cicalese):
[operations/mediawiki-config@master] Configuration for user menu and sidebar special pages

https://gerrit.wikimedia.org/r/634543

Change 634543 merged by jenkins-bot:
[operations/mediawiki-config@master] Configuration for user menu and sidebar special pages

https://gerrit.wikimedia.org/r/634543

Change 634335 merged by jenkins-bot:
[mediawiki/skins/WikimediaApiPortal@master] Handle extra user menu and sidebar special pages.

https://gerrit.wikimedia.org/r/634335

The two new config variables need to be documented on the extension page.

Change 634356 merged by jenkins-bot:
[operations/mediawiki-config@master] Configuration for user menu and sidebar special pages.

https://gerrit.wikimedia.org/r/634356

Documented new config variables on mediawiki.org

apaskulin closed this task as Resolved.Oct 19 2020, 5:04 PM

Confirmed on beta. Thanks, Cindy!