Page MenuHomePhabricator

Task preview data incorrectly set when user uses non-default task/topic selections
Closed, ResolvedPublicBUG REPORT

Description

Steps to reproduce:

  1. Create an account with Variant A or D (C doesn't have this problem, since it is already initiated)
  2. Go through the initiation process and select a combination of topics and tasks such that the article counter shows "0"
  3. Click "Done" to finish the initiation

Expected results:

  • The "No results" card in the Suggested Edits module, since I have selected task/topic combination that provides 0 results

Actual results:

  • One card appears.

The single card appears because on the server-side we export a single task to the front-end with the intention of rendering it for mobile Variant C and D users. Later the logic was loosened so that it was shown for all users (since this is a little more performant for the server-side rendering on desktop too). However, we didn't check if the module was already activated before attempting to export this card. As a result we made a query to get tasks using the default filters (no topics, copyedit/links task types). Then we exported a card from that result set to the front-end. After that, the user finishes activation and instead of 0 results, they see this default card, which also goes away on page refresh, since the task type filters of the user don't correspond to the default topic/task type filters. The problem also occurs if the user selects for example only "Hard" difficulty tasks; after activation, they will first see an "Easy" task since that was generated as part of the task preview data.

Event Timeline

kostajh created this task.Oct 1 2020, 2:09 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 1 2020, 2:09 PM
kostajh claimed this task.Oct 1 2020, 2:09 PM
kostajh changed the subtype of this task from "Task" to "Bug Report".
kostajh moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

Change 631451 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Only preload task cards for users who have activated the SE module

https://gerrit.wikimedia.org/r/631451

kostajh renamed this task from Task preview data incorrectly set when user selects no articles to Task preview data incorrectly set when user uses non-default task/topic selections.Oct 1 2020, 2:14 PM
kostajh updated the task description. (Show Details)

Change 631451 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Only preload task cards for users who have activated the SE module

https://gerrit.wikimedia.org/r/631451

@kostajh - There is another issue that might be related to this one (not sure). For all variants there is a card shown briefly with "0 of 0" displayed (on enwiki betalabs the filter selection o get 0 reaults: "Add link"+"Literature"):

It's quite noticeable even on fast network connection (click on the gif below):

The issue is present now in testwiki wmf.10 (the filter combination for 0 results: "Add link"+"Medicine and health". Do you think it's a different issue or it's somehow another manifestation of the issue in this phab task?

Yeah, doesn't look great. This is a separate issue from this task though. I'd propose we handle it in T236738: Newcomer tasks: server-side rendered version of suggested edits module if that's alright?

Change 633984 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] SE: Show no results card if we know there are no results

https://gerrit.wikimedia.org/r/633984

Yeah, doesn't look great. This is a separate issue from this task though. I'd propose we handle it in T236738: Newcomer tasks: server-side rendered version of suggested edits module if that's alright?

Actually, while we should address it in T236738 as well, the fix with our current set up is pretty straightforward so I've pushed a patch for that.

Change 633984 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] SE: Show no results card if we know there are no results

https://gerrit.wikimedia.org/r/633984

Etonkovidova closed this task as Resolved.Oct 19 2020, 9:47 PM

Checked - looks great. Added to the list to check after deploy.