Dialogs broken when mwEmbed is enabled
Closed, DeclinedPublic

Description

Using the dialogs on current wikipedia installations results in the following error (Search and replace and insert link):

TypeError: Result of expression '$('<div />').attr('id',module.id).html(module.html).data('context',context).appendTo($('body')).each(module.init).dialog' [undefined] is not a function.

Occurs with Safari 5, Chrome, and Opera 10 on Mac OS X Snow Leopard, but works on FF4.


Version: unspecified
Severity: critical

Details

Reference
bz24528
bzimport set Reference to bz24528.
bzimport added a subscriber: Unknown Object (MLST).
TheDJ created this task.Jul 24 2010, 3:44 PM

amiller1 wrote:

Here's what I was able to figure out so far:

Only occurs when both Twinkle and mwEmbed gadgets are enabled. Once they are enabled, it seems like jquery ui is not loaded on the edit page.

usermono wrote:

I disabled mwembed, working now without that, so you know...

usermono wrote:

Screenshot of issue.

Attached:

TheDJ added a comment.Oct 18 2010, 9:43 AM

This is fixed now for me. mwEmbed + Twinkle + dialogs seems to work.

usermono wrote:

Not fixed for me...

Michael, can such mwEmbed bug be closed (isn't it superseded?)?

mdale wrote:

We should disable the mwEmbed gadget now that Timed media handler is being enabled.

(In reply to comment #9)

We should disable the mwEmbed gadget now that Timed media handler is being
enabled.

Can you please do so on en.wiki, Commons and any other wiki using it by disabling/blanking it then? (You have global editinterface rights.)

TheDJ added a comment.Nov 6 2012, 6:19 PM

I had already removed it from en.wp and commons a while ago. Not sure if it is used anywhere else.

WONTFIXing as we slowly get rid of mwEmbed anyway.
Plus no clear steps to reproduce nowadays...

Add Comment