Page MenuHomePhabricator

Expectation (masterConns <= 0) by ApiMain::setRequestExpectations not met (actual: 1):[connect to 10.192.0.120 (mediawikiwiki)]
Closed, ResolvedPublicPRODUCTION ERROR

Description

Error

MediaWiki version: 1.36.0-wmf.13

message
Expectation (masterConns <= 0) by ApiMain::setRequestExpectations not met (actual: 1):
[connect to 10.192.0.120 (mediawikiwiki)]

Impact

Noise in logs, and we shouldn't be connecting to main DB on a GET request.

Notes

Details

Request ID
c8421a0d-dd7c-4f03-8094-724a8611ce89
Request URL
https://www.mediawiki.org/w/api.php?action=flow&format=json&submodule=view-topiclist&page=User_talk%3AGeniFrenchhiker66&vtloffset=0&vtllimit=50&vtlsortby=newest&vtlsavesortby=1
Stack Trace
exception.trace
#0 /srv/mediawiki/php-1.36.0-wmf.13/includes/libs/rdbms/TransactionProfiler.php(189): Wikimedia\Rdbms\TransactionProfiler->reportExpectationViolated(string, string, integer)
#1 /srv/mediawiki/php-1.36.0-wmf.13/includes/libs/rdbms/loadbalancer/LoadBalancer.php(943): Wikimedia\Rdbms\TransactionProfiler->recordConnection(string, string, boolean)
#2 /srv/mediawiki/php-1.36.0-wmf.13/includes/libs/rdbms/loadbalancer/LoadBalancer.php(899): Wikimedia\Rdbms\LoadBalancer->getServerConnection(integer, string, integer)
#3 /srv/mediawiki/php-1.36.0-wmf.13/includes/libs/rdbms/loadbalancer/LoadBalancer.php(1030): Wikimedia\Rdbms\LoadBalancer->getConnection(integer, array, string, integer)
#4 /srv/mediawiki/php-1.36.0-wmf.13/includes/user/UserOptionsManager.php(596): Wikimedia\Rdbms\LoadBalancer->getConnectionRef(integer, array)
#5 /srv/mediawiki/php-1.36.0-wmf.13/includes/user/UserOptionsManager.php(526): MediaWiki\User\UserOptionsManager->getDBForQueryFlags(integer)
#6 /srv/mediawiki/php-1.36.0-wmf.13/includes/user/UserOptionsManager.php(187): MediaWiki\User\UserOptionsManager->loadUserOptions(User, integer)
#7 /srv/mediawiki/php-1.36.0-wmf.13/includes/user/User.php(2605): MediaWiki\User\UserOptionsManager->setOption(User, string, string)
#8 /srv/mediawiki/php-1.36.0-wmf.13/extensions/Flow/includes/Block/TopicListBlock.php(425): User->setOption(string, string)
#9 /srv/mediawiki/php-1.36.0-wmf.13/extensions/Flow/includes/Block/TopicListBlock.php(259): Flow\Block\TopicListBlock->getFindOptions(array)
#10 /srv/mediawiki/php-1.36.0-wmf.13/extensions/Flow/includes/Api/ApiFlowBaseGet.php(33): Flow\Block\TopicListBlock->renderApi(array)
#11 /srv/mediawiki/php-1.36.0-wmf.13/extensions/Flow/includes/Api/ApiFlow.php(105): Flow\Api\ApiFlowBaseGet->execute()
#12 /srv/mediawiki/php-1.36.0-wmf.13/includes/api/ApiMain.php(1566): Flow\Api\ApiFlow->execute()
#13 /srv/mediawiki/php-1.36.0-wmf.13/includes/api/ApiMain.php(546): ApiMain->executeAction()
#14 /srv/mediawiki/php-1.36.0-wmf.13/includes/api/ApiMain.php(517): ApiMain->executeActionWithErrorHandling()
#15 /srv/mediawiki/php-1.36.0-wmf.13/api.php(90): ApiMain->execute()
#16 /srv/mediawiki/php-1.36.0-wmf.13/api.php(45): wfApiMain()
#17 /srv/mediawiki/w/api.php(3): require(string)
#18 {main}

Event Timeline

kostajh created this task.Oct 15 2020, 12:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 15 2020, 12:02 PM

Change 634212 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/Flow@master] Save sortby preference in a job

https://gerrit.wikimedia.org/r/634212

kostajh moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

This was making noise in the logs, so while looking at the cause I found it is trivial to fix. Growth engineers -- please do not prioritize code review of this over other pre-defined interlude work; I've added it it to our current sprint so it can go through the normal code review / QA process.

kostajh claimed this task.Oct 19 2020, 11:44 AM

Change 634212 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Save sortby preference in a job

https://gerrit.wikimedia.org/r/634212

Etonkovidova closed this task as Resolved.Oct 22 2020, 11:16 PM