Page MenuHomePhabricator

When posting two replies to transcluded comments without reloading the page, the second reply may be lost or posted on the wrong page
Closed, ResolvedPublic

Description

When posting two replies to transcluded comments without reloading the page, the second reply may be lost or posted on the wrong page.

I discovered this when testing T266195, and it can be reproduced on the same page now that that bug was fixed: https://en.wikipedia.beta.wmflabs.org/wiki/Talk:T266195

This happens because we don't clear our cache of the "transcluded from" data for comments after posting. So we send the reply to the wrong page, and it either disappears inside the transclusion due to Parsoid stuff, or actually might get posted there (theoretically, I didn't run into that when testing).

Event Timeline

matmarex created this task.Oct 22 2020, 7:43 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 22 2020, 7:43 PM

Change 635885 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/DiscussionTools@master] Clear page data cache after posting a reply

https://gerrit.wikimedia.org/r/635885

It's a bit hard to describe, so here's a screen recording for reference:

Note how the message "Your comment will be saved at…" is missing the second time, that's the smoking gun.

Change 635885 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Clear page data cache after posting a reply

https://gerrit.wikimedia.org/r/635885

JTannerWMF closed this task as Resolved.Wed, Nov 25, 6:14 PM
JTannerWMF claimed this task.