Page MenuHomePhabricator

Unable to semi-protect properties on Wikidata
Closed, DeclinedPublic

Description

I noticed that use Edit=Allow only autoconfirmed users for items and for pages in the project namespace, but for properties the option seems to be gone. As an admin you can see this at https://www.wikidata.org/w/index.php?title=Property:P3452&action=unprotect for example.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptTue, Oct 27, 6:06 PM
Ammarpad added a subscriber: Ammarpad.EditedTue, Oct 27, 6:16 PM

This is because the entire namespace has been protected with that same level: T254280.

DannyS712 closed this task as Declined.Tue, Oct 27, 8:14 PM
DannyS712 added subscribers: Anomie, DannyS712.

This is intentional, since the namespace is protected
See rMW8862991ce1b1: Improve UI for page protection with $wgNamespaceProtection by @Anomie

Still means the wording of the protect page is incorrect. Currently it says "all users" and "allow only administrators". The "all users" is not correct because changing the protection to that won't make it possible for all users to edit, only for autoconfirmed users and above. I see we have T266394 for that

Anomie removed a subscriber: Anomie.Wed, Oct 28, 1:30 AM
Ammarpad removed a subscriber: Ammarpad.Wed, Oct 28, 4:44 AM