Page MenuHomePhabricator

Fix Storybook gallery view
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

Open the storybook: https://wikimedia.github.io/wikipedia-preview/storybook-static/

Actual Results:

The first page is the fullscreen gallery view... and it is broken

Expected Results:
  1. It should open up with and image and all 3 preconfigured images should work.
  2. The gallery error state could be illustrated as a different entry (bonus points)

Event Timeline

SBisson created this task.Oct 28 2020, 2:10 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 28 2020, 2:10 PM
SBisson triaged this task as Medium priority.Oct 28 2020, 2:10 PM
hueitan claimed this task.Nov 16 2020, 8:15 AM
hueitan moved this task from Ready for Dev to Dev on the Inuka-Team (Kanban) board.
hueitan added a comment.EditedNov 16 2020, 8:56 AM

Note: This is caused by the change of having a new api called when loading the image info, can be fixed either feed the correct api or isolate gallery slider and image info component.

SBisson moved this task from Code Review to QA on the Inuka-Team (Kanban) board.Nov 16 2020, 6:30 PM

The PR is merged

Jpita added a subscriber: Jpita.

is this just for storybook or also for the actual preview code?

only the storybook

Jpita moved this task from QA to Design sign off on the Inuka-Team (Kanban) board.Nov 16 2020, 9:08 PM
AMuigai updated the task description. (Show Details)Nov 17 2020, 12:36 PM
AMuigai closed this task as Resolved.Nov 17 2020, 6:09 PM