Page MenuHomePhabricator

Requesting access to prod cluster for annet
Closed, ResolvedPublicRequest

Description

Requestor provided information and prerequisites

This section is to be completed by the individual requesting access.

  • Wikitech username: annet
  • Preferred shell username: annet
  • Email address: atomasevich@wikimedia.org
  • Ssh public key (must be dedicated key for wmf production): ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIAG6XeNu2cHXzdcTYGlMcLldBAzYT3eEeoLwJzZCma29 atomasevich@MacBook-Pro.localdomain
  • Requested group membership: deployment
  • Reason for access: Need rights to deploy code changes to the production cluster
  • Name of approving party (hiring manager for WMF staff): Mark Holmquist
  • Requestor -- Please Acknowledge that you have read and signed the L3 Wikimedia Server Access Responsibilities document: I have read and signed the L3 Wikimedia Server Access Responsibilities document
  • Requestor -- Please coordinate obtaining a comment of approval on this task from the approving party.

SRE Clinic Duty Confirmation Checklist for Access Requests

This checklist should be used on all access requests to ensure that all steps are covered, including expansion to existing access. Please double check the step has been completed before checking it off.

This section is to be confirmed and completed by a member of the SRE team.

  • - User has signed the L3 Acknowledgement of Wikimedia Server Access Responsibilities Document.
  • - User has a valid NDA on file with WMF legal. (This can be checked by Operations via the NDA tracking sheet & is included in all WMF Staff/Contractor hiring.)
  • - User has provided the following: wikitech username, preferred shell username, email address, and full reasoning for access (including what commands and/or tasks they expect to perform)
  • - User has provided a public SSH key. This ssh key pair should only be used for WMF cluster access, and not share with any other service (this includes not sharing with WMCS access, no shared keys.)
  • - access request (or expansion) has sign off of WMF sponsor/manager (sponser for volunteers, manager for wmf staff)
  • - non-staff requests: 3 business day wait must pass with no objections being noted on the task
  • - Patchset for access request

For additional details regarding access request requirements, please see https://wikitech.wikimedia.org/wiki/Requesting_shell_access

Event Timeline

AnneT created this task.Wed, Oct 28, 9:47 PM
Restricted Application added a project: Operations. · View Herald TranscriptWed, Oct 28, 9:47 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Approving as manager.

Dzahn updated the task description. (Show Details)Fri, Oct 30, 3:31 AM
Dzahn added a subscriber: Dzahn.Fri, Oct 30, 3:35 AM

Confirming L3 is signed. Checked first box.

Confirmed is employee (`[ldap-corp1001:~] $ /usr/bin/ldapsearch -x "mail=atoma*@*"), https://www.mediawiki.org/wiki/User:ATomasevich_(WMF). Checked second box.
`

Dzahn updated the task description. (Show Details)Fri, Oct 30, 3:37 AM
Dzahn added a comment.Fri, Oct 30, 3:40 AM

Confirmed wikitech user ([mwmaint1002:~] $ /usr/bin/ldapsearch -x "uid=annet*")

Confimed manager (`[ldap-corp1001:~] $ /usr/bin/ldapsearch -x "mail=atoma*@*" | grep manager)

Has approval, does not need 3 day wait, wikitech user uses official wmf email`

Checks all other boxes. Uploading patch.

Change 637588 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] admin: add AnneT to deployers

https://gerrit.wikimedia.org/r/637588

Dzahn added a comment.Fri, Oct 30, 3:48 AM

patch in review, added some people including releng which we usually do for all new deployers

Dzahn triaged this task as Medium priority.Fri, Oct 30, 3:49 AM

Change 637588 merged by Ema:
[operations/puppet@production] admin: add AnneT to deployers

https://gerrit.wikimedia.org/r/637588

ema updated the task description. (Show Details)Fri, Oct 30, 10:52 AM
ema added a subscriber: ema.

@AnneT: please let us know if everything is working as expected!

AnneT added a comment.Fri, Oct 30, 7:54 PM

Looks like all is working, thanks @ema and @Dzahn!

Dzahn closed this task as Resolved.Fri, Oct 30, 10:19 PM
Dzahn claimed this task.

@AnneT Thanks for confirming that. I'll call the ticket resolved.