Page MenuHomePhabricator

Media Search filters display behind other content on iOS + safari
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce: Visit Special:MediaSearch in iOS (confirmed that this is an issue in Safari, but it probably exists in other browsers too)

Actual Results: Select menu appears hidden behind other content

Expected Results: Select menu should be visible

This is caused by the CSS rule -webkit-overflow-scrolling: touch; on the parent container, which is intended to enable momentum-based scrolling horizontally for the filters, but is having the unintended consequence of hiding content on the y-axis as well.

Event Timeline

AnneT created this task.Oct 30 2020, 7:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 30 2020, 7:02 PM

Change 637766 had a related patch set uploaded (by Anne Tomasevich; owner: Anne Tomasevich):
[mediawiki/extensions/WikibaseMediaInfo@master] Remove momentum-based scrolling for webkit browsers

https://gerrit.wikimedia.org/r/637766

Change 637766 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Remove momentum-based scrolling for webkit browsers

https://gerrit.wikimedia.org/r/637766

Etonkovidova closed this task as Resolved.EditedNov 24 2020, 2:56 AM
Etonkovidova added a subscriber: Etonkovidova.

I noticed the bug - it was not reproducible in any of the emulators only on a real device which was iPhone 6s (iOS 13.7). Also run through usual cross-browser testing
Checked on commons wmf.18 - the fix is in place.