Page MenuHomePhabricator

Fix moderation of membership application
Closed, ResolvedPublic5 Estimated Story Points

Description

The moderation feature of the membership application list is broken.

Steps to reproduce

  • Request a list of recent membership applications in the Ops Center.
  • Set the maximum number of entries to a higher value and/or browse through the list to see an entry displayed in red text color.
  • Click the lock icon to unblock the entry.

Expected behaviour

  • The browser requests the server to unblock the data set.
  • The text color of the entry switches to black.

Actual behaviour

  • The browser requests the server to unblock the data set.
  • The server sends an empty response.
  • An error occurs in the browser (see below).
  • The activity indicator keeps spinning.
Uncaught TypeError: Cannot read property 'status' of null
    at Object.success (memberlist.js:210)
    at fire (jquery-1.8.2.js:974)
    at Object.fireWith [as resolveWith] (jquery-1.8.2.js:1082)
    at done (jquery-1.8.2.js:7788)
    at XMLHttpRequest.callback (jquery-1.8.2.js:8500)

Notes

  • The function that the lock icon executes used to depend on the data set's status. It looks like this is currently reversed, displaying the block icon for data sets that are locked and vice versa. The browser also seems to request the wrong entry point (lock vs unlock).
  • We should check why the server side returns an empty response.
  • We should also try to make the client-side code more robust to make sure the application isn't blocked when an error like this occurs.

Event Timeline

Restricted Application added a project: WMDE-FUN-Team. · View Herald TranscriptNov 2 2020, 8:43 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
kai.nissen updated the task description. (Show Details)Nov 2 2020, 8:44 AM
kai.nissen moved this task from Heap to Incubation on the WMDE-FUN-Funban-2020 board.
kai.nissen updated the task description. (Show Details)Nov 2 2020, 10:27 AM
kai.nissen set the point value for this task to 5.
kai.nissen moved this task from Incubation to Heap on the WMDE-FUN-Funban-2020 board.
AbbanWMDE claimed this task.Nov 6 2020, 7:44 AM
AbbanWMDE moved this task from Heap to Doing on the WMDE-FUN-Funban-2020 board.
AbbanWMDE removed AbbanWMDE as the assignee of this task.Nov 9 2020, 6:27 AM
AbbanWMDE moved this task from Doing to Code Review on the WMDE-FUN-Funban-2020 board.
AbbanWMDE added a subscriber: AbbanWMDE.
This comment was removed by CorinnaHillebrand_WMDE.
kai.nissen closed this task as Resolved.Thu, Jan 7, 11:41 AM
kai.nissen claimed this task.