Page MenuHomePhabricator

Upload wizard: Add bail options
Closed, DeclinedPublic

Description

We discussed this already, but there isn't currently an option for the user to quit the upload and explicitly cancel the upload.

Places where I would see this option:

  • at the bottom left, like a counterpart to the "next" button
  • on step 2, for people who want to cancel it because they don't know, or because they made a mistake

Version: unspecified
Severity: minor

Details

Reference
bz24762

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:07 PM
bzimport added a project: UploadWizard.
bzimport set Reference to bz24762.
gpaumier created this task.Aug 11 2010, 9:03 PM

soxred93 wrote:

I disagree with the need, and agree with the sentiment expressed here: http://www.useit.com/alertbox/20000416.html

Well, I do agree with this article as well (and many other articles from useit's alertbox), and it seems to support the need for a cancel button:

« Offer a Cancel button when users may fear that they have committed to something they want to avoid. Having an explicit way to Cancel provides an extra feeling of safety that is not afforded by simply leaving.

Cancel is mainly useful for multi-step dialogs where the user has progressed past one or more pages with actions. At this time, pressing the Back button will not undo these actions and it would be better if the user would click Cancel. »

This is exactly our case.

Users are going to upload one or several files and they may want to cancel the upload if they feel they didn't understand the copyright terms right, for example. Besides, our upload wizard is indeed a "multi-step dialog where the user has progress past one of more pages with actions".

  • Bug 28333 has been marked as a duplicate of this bug. ***

neilk wrote:

fixed in r86594

Gilles moved this task from Untriaged to Done on the Multimedia board.Dec 4 2014, 10:41 AM
El_Grafo reopened this task as Open.Jun 3 2015, 9:19 AM
El_Grafo set Security to None.

I'm currently in the "Release rights" step and if there's supposed to be a cancel button anywhere, it's not visible to me (Firefox 37.0.1 on an older Ubuntu LTS).

El_Grafo moved this task from Done to Untriaged on the Multimedia board.Jun 17 2015, 9:01 AM
Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:23 PM
Restricted Application added subscribers: Steinsplitter, Matanya, Aklapper. · View Herald TranscriptSep 4 2015, 6:23 PM
El_Grafo moved this task from Incoming to Uploading on the Commons board.
MarkTraceur closed this task as Declined.Dec 3 2015, 7:49 PM
MarkTraceur claimed this task.

I agree with the sentiments stated very early in this bug, but not for the exact same reasons as in the article. If you want to restart the entire upload process, there's a way to do that, it's called the refresh button in your browser.

Knowing about the refresh button requires advanced computer literacy and isn't an obvious thing to do to reset a wizard. People are going through different steps, mentally they're on a different page, refreshing shouldn't logically bring them back to the start.

It just does because we don't update the URL. Knowing about how URLs work requires an even more advanced level of computer literacy. And in some cases browsers go out of their way to hide the full URL now.

All in all, knowing that the browser's refresh button does this in UploadWizard has to be learned, it's not intuitive.

My original bug report was regarding the lack of possibility to go a step back in the process, e.g. unselecting a picute/adding another one, changing the filename etc.
I think this issue is still not solved: https://phabricator.wikimedia.org/T38583