Page MenuHomePhabricator

decommission es1011.eqiad.wmnet
Closed, ResolvedPublicRequest

Description

This task will track the decommission-hardware of server es1011.eqiad.wmnet

With the launch of updates to the decom cookbook, the majority of these steps can be handled by the service owners directly. The DC Ops team only gets involved once the system has been fully removed from service and powered down by the decommission cookbook.

es1011

Steps for service owner:

  • - all system services confirmed offline from production use
  • - set all icinga checks to maint mode/disabled while reclaim/decommmission takes place.
  • - remove system from all lvs/pybal active configuration
  • - any service group puppet/hiera/dsh config removed
  • - remove site.pp, replace with role(spare::system) recommended to ensure services offline but not 100% required as long as the decom script is IMMEDIATELY run below.
  • - login to cumin host and run the decom cookbook: cookbook sre.hosts.decommission <host fqdn> -t <phab task>. This does: bootloader wipe, host power down, netbox update to decommissioning status, puppet node clean, puppet node deactivate, debmonitor removal.
  • - remove all remaining puppet references (include role::spare) and all host entries in the puppet repo
  • - remove ALL dns entries except the asset tag mgmt entries.
  • - reassign task from service owner to DC ops team member depending on site of servee.

End service owner steps / Begin DC-Ops team steps:

  • - disable switch port / set to asset tag if host isn't being unracked / remove from switch if being unracked.
  • - system disks removed (by onsite)
  • - determine system age, under 5 years are reclaimed to spare, over 5 years are decommissioned.
  • - IF DECOM: system unracked and decommissioned (by onsite), update netbox with result and set state to offline
  • - IF DECOM: switch port configuration removed from switch once system is unracked.
  • - IF DECOM: mgmt dns entries removed.
  • - IF RECLAIM: set netbox state to 'inventory' and hostname to asset tag

Event Timeline

Marostegui raised the priority of this task from Medium to High.Wed, Nov 18, 8:17 AM
Marostegui moved this task from Triage to In progress on the DBA board.

Setting this to high as we need to make space for x2 hosts (T267043#6606399)

Marostegui updated the task description. (Show Details)Wed, Nov 18, 8:29 AM

Change 641688 had a related patch set uploaded (by Marostegui; owner: Marostegui):
[operations/puppet@production] mariadb: Disable notifications on es1011,es1012,es1014.

https://gerrit.wikimedia.org/r/641688

Change 641688 merged by Marostegui:
[operations/puppet@production] mariadb: Disable notifications on es1011,es1012,es1014.

https://gerrit.wikimedia.org/r/641688

Marostegui updated the task description. (Show Details)Wed, Nov 18, 8:32 AM

Mentioned in SAL (#wikimedia-operations) [2020-11-18T08:34:47Z] <marostegui> Stop MySQL on es1011, es1012, es1014 T268100 T268101 T268102

Marostegui updated the task description. (Show Details)Wed, Nov 18, 8:35 AM

Change 641968 had a related patch set uploaded (by Marostegui; owner: Marostegui):
[operations/puppet@production] mariadb: Decommission es1011

https://gerrit.wikimedia.org/r/641968

cookbooks.sre.hosts.decommission executed by marostegui@cumin1001 for hosts: es1011.eqiad.wmnet

  • es1011.eqiad.wmnet (FAIL)
    • Downtimed host on Icinga
    • Found physical host
    • Downtimed management interface on Icinga
    • Wiped bootloaders
    • Powered off
    • Host steps raised exception: The request failed with code 500 Internal Server Error but more specific details were not returned in json. Check the NetBox Logs or investigate this exception's error attribute.

ERROR: some step on some host failed, check the bolded items above

Change 641968 merged by Marostegui:
[operations/puppet@production] mariadb: Decommission es1011

https://gerrit.wikimedia.org/r/641968

Marostegui updated the task description. (Show Details)Thu, Nov 19, 12:01 PM

cookbooks.sre.hosts.decommission executed by volans@cumin1001 for hosts: es1011.eqiad.wmnet

  • es1011.eqiad.wmnet (FAIL)
    • Downtimed host on Icinga
    • Found physical host
    • Downtimed management interface on Icinga
    • Unable to connect to the host, wipe of bootloaders will not be performed: Cumin execution failed (exit_code=2)
    • Powered off
    • Set Netbox status to Decommissioning and deleted all non-mgmt interfaces and related IPs
    • Removed from DebMonitor
    • Removed from Puppet master and PuppetDB

ERROR: some step on some host failed, check the bolded items above

Marostegui edited projects, added ops-eqiad, DC-Ops; removed Patch-For-Review, DBA.

Ready for DC-Ops
The reason for this task to be high priority is at T268100#6629562

Restricted Application added a project: Operations. · View Herald TranscriptThu, Nov 19, 2:52 PM
Marostegui updated the task description. (Show Details)Thu, Nov 19, 2:52 PM
wiki_willy added a subscriber: wiki_willy.

Thanks for freeing up the rack space here @Marostegui , for the incoming X2 servers.

Thanks,
Willy

Cmjohnson moved this task from Backlog to Decommission on the ops-eqiad board.Thu, Nov 19, 6:05 PM
Cmjohnson closed this task as Resolved.Wed, Nov 25, 8:20 PM

done and off the rack