Page MenuHomePhabricator

MW 1.35.0 "Error contacting the Parsoid/RESTBase server: http-bad-status" when editing a subpage
Closed, InvalidPublicBUG REPORT

Description

Steps to Reproduce:

Configure a MediaWiki 1.35 instance with :

$wgNamespacesWithSubpages[NS_MAIN] = true;

Create and then attempt to edit a subpage with VisualEditor

Actual Results:

Error message: "Error contacting the Parsoid/RESTBase server: http-bad-status"

Expected Results:

VisualEditor loads without error.

Notes:

Only subpages are broken. VisualEditor seems to work well on normal pages. Also, editing source with VisualEditor works fine on all articles, even subpages.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 29 2020, 8:29 PM
Reedy added a subscriber: Reedy.Nov 29 2020, 9:04 PM

And for clarity... Editing non subpage pages actually work?

And for clarity... Editing non subpage pages actually work?

Yes. /wiki/Foo is editable with VisualEditor. /wiki/Foo/Bar throws the error.

Metalliqaz updated the task description. (Show Details)Nov 30 2020, 1:35 AM

This seems to be a WFM on master (at least).

I need to get a REL1_35 dev wiki up this week for testing a few other things

Reedy added a comment.Nov 30 2020, 2:34 AM

Right... so do you get the error when you're trying to open the edit page? Or when trying to actually save the page?

master and REL1_35, opening the edit is fine...

*but* when I try and save a page (on both branches), I get Error contacting the Parsoid/RESTBase server (HTTP 404)

I assume WFM means "works for me". If needed I can provide additional information. I just couldn't find anything relating to the error. The API response had very little information in it.

For me, it fails when opening the page for editing.

ppelberg moved this task from To Triage to Triaged on the VisualEditor board.Dec 1 2020, 4:16 PM

Assuming you're using Apache, can you try adding AllowEncodedSlashes NoDecode to the virtual host configuration? (This is documented at https://www.mediawiki.org/wiki/Extension:VisualEditor#Troubleshooting, but under a slightly different error message than you're getting, which is interesting.)

Assuming you're using Apache, can you try adding AllowEncodedSlashes NoDecode to the virtual host configuration? (This is documented at https://www.mediawiki.org/wiki/Extension:VisualEditor#Troubleshooting, but under a slightly different error message than you're getting, which is interesting.)

Ok I am using Apache but I'm not using VitualHost. Anyway I added that setting to the config file and it seems to have worked. I can edit subpages with VisualEditor now.

Thank you and sorry to create a bug report for something that was documented in the wiki. I will add that error message to the troubleshooting section on the wiki.

Reedy moved this task from Blocker to Non blocker on the MW-1.35-release board.Dec 2 2020, 1:52 AM
cscott added a subscriber: cscott.Dec 15 2020, 5:11 PM

I can confirm this is necessary to edit page titles containing slashes (whether they are subpages or not). I've added the apache information to the main VE configuration section: https://www.mediawiki.org/w/index.php?title=Extension:VisualEditor&type=revision&diff=4285160&oldid=4258839&diffmode=source

matmarex closed this task as Invalid.Dec 15 2020, 10:32 PM

Per above, not a VisualEditor bug, just a configuration problem. Thanks for documenting that!