Page MenuHomePhabricator

Add a "private message" and "report" and UTRS-like feature into MediaWiki
Closed, InvalidPublic

Description

This may sound like a lot, and anyone is free to split this, but these three key features are important for moderation and communication with editors and should be built-in to MediaWiki (either as extensions or in MediaWiki core).

  1. Private message - not everyone has or is willing to give out an email address. This can make private communications difficult. For example, if I had a question for an editor or just wanted "general chat" on a wiki, I would have to use email, which has the problem that it can potentially expose your email address. Or if an administrator wanted to coach someone without causing public embarrassment, private messaging is good for that. Of course, users that abuse the system should be able to be blocked from sending (but not receiving) private messages. And the private messages could support the MediaWiki markup.
  2. Report feature - the goal of this is to get the immediate attention of administrators about issues like vandalism or spam. On a few wikis I edit, they just have an "admin noticeboard", which, while it does get the attention of administrators, admins are too slow to respond. When I leave a message for a recently active admin, I get a much faster response. Having this and an opt-out reporting system for admins to review user's actions is important. A user should be able to immediately be given automatically escalating blocks through the report form. And users should be able to track the status of their report (perhaps through private messaging or email). They should be private (but can be made public).
  3. Block appeal form - on the English Wikipedia, there is UTRS, but the issue is that users are directed to a separate site (also hosted on WMF) to submit appeals. Also, when the service is down for maintenance, there is no way for blocked users to submit appeals. Finally, the old UTRS system required an email address, and not everyone is willing to give out their email address. Beyond Wikipedia, there is no universal system for appealing blocks. This system would have a separate page and a link on the sidebar of admins showing the number of appeals pending. The appeal can either be placed on hold, accepted, or declined. The blocked user cannot send another appeal until the first appeal is rejected, and if an appeal is rejected then the blocked user cannot send another appeal for 1 day, then 2 days, then 4 days, then 8 days, and so on. The blocked user can be notified as well about the status of their appeal (maybe again through private messaging).

All three of these proposed systems should be logged publicly. The report feature could also be private by default and made public if the report does not contain sensitive information or deleted.

See also:
T119241: Allow autoconfirmed users to report edits to oversighters
T121639: Provide a way to report local hideuser blocks for global CentralAuth oversight

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 2 2020, 9:19 AM
Bugreporter updated the task description. (Show Details)Dec 2 2020, 9:28 AM
Aklapper closed this task as Invalid.Dec 2 2020, 9:43 AM

Hi @Awesome_Aasim, thanks for taking the time to report this! Please always follow https://www.mediawiki.org/wiki/How_to_report_a_bug and report/request only one single specific bug or feature per ticket. I'm closing this ticket as invalid as it is not actionable - one cannot track status per task status, one cannot have focused conversations as this ticket covers way too many things.
Also note that bullet point to sounds like T166812.

@Aklapper thank you for the feedback. :)

Awesome_Aasim added a comment.EditedDec 2 2020, 9:53 AM

Okay... I focused on one specific task at hand right now. Someone probably already asked this before but the task is located at T269210.