Page MenuHomePhabricator

Support ECMAScript 2015+ on ResourceLoader
Closed, DuplicatePublic

Description

Currently, ResourceLoader supports only ECMAScript 5, which is 11 years old standard. ES5 restriction on ResourceLoader forces to use inefficient codes.

Most modern web browsers (except IE) support the up-to-date ES Standard.

I wish the RL supports contemporary ECMAScript standards for most modern browsers.