Page MenuHomePhabricator

Time to require PHP 7.2+?
Closed, ResolvedPublic


The extension's composer.json reads:

"php": ">=5.5.9"

But the code is already using PHP 7.1 nullable types, as spotted by phan in Perhaps it's time to bump the requirement to PHP 7.2+? Or is these some good reason to keep it at 5.5, and we should remove PHP 7 features?

Related Objects

Event Timeline

Change 648771 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/] composer: Don't specify PHP version

Yeah, this repo is for production code only – – so no need for old PHP support at all.

Change 648771 merged by jenkins-bot:
[mediawiki/extensions/] composer: Don't specify PHP version