Page MenuHomePhabricator

Time to require PHP 7.2+?
Closed, ResolvedPublic

Description

Copying from T269756:

The extension's composer.json reads:

"php": ">=5.5.9"

But the code is already using PHP 7.1 nullable types, as spotted by phan in https://gerrit.wikimedia.org/r/c/mediawiki/extensions/WikibaseQualityConstraints/+/647227. Perhaps it's time to bump the requirement to PHP 7.2+? Or is these some good reason to keep it at 5.5, and we should remove PHP 7 features?

Related Objects

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Or is these some good reason to keep it at 5.5, and we should remove PHP 7 features?

Nah, I expect we just didn’t get around to updating it yet. Pretty sure we can require 7.2.

Change 647263 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/WikibaseQualityConstraints@master] Bump PHP requirement

https://gerrit.wikimedia.org/r/647263

Change 647263 merged by jenkins-bot:
[mediawiki/extensions/WikibaseQualityConstraints@master] Bump PHP requirement

https://gerrit.wikimedia.org/r/647263