Page MenuHomePhabricator

Update php requirement for CentralAuth to 7.2
Closed, ResolvedPublic

Description

The extension's composer.json reads:

"php": ">=5.5.9"

But the code is already using PHP 7.1 nullable types, as spotted by phan in https://gerrit.wikimedia.org/r/c/mediawiki/extensions/CentralAuth/+/647431. Perhaps it's time to bump the requirement to PHP 7.2+? Or is these some good reason to keep it at 5.5, and we should remove PHP 7 features?

Event Timeline

Or just remove it completely.

The one in master depends on MW >= 1.35.0, so technically could be 7.3.

An extension only needs it if it's more restrictive than MW core (more likely if it still actually supports multiple MW versions)

Change 647801 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/CentralAuth@master] composer.json: Remove php requirement

https://gerrit.wikimedia.org/r/647801

Daimona claimed this task.
Daimona added a subscriber: Daimona.

I totally agree with the removal, it's pointless to keep it there, eventually it'll just become an out-of-date copy of what's in core's composer.json (in fact, it already is obsolete).

Change 647645 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/CentralAuth@REL1_35] composer.json: Remove php requirement

https://gerrit.wikimedia.org/r/647645

Change 647801 merged by jenkins-bot:
[mediawiki/extensions/CentralAuth@master] composer.json: Remove php requirement

https://gerrit.wikimedia.org/r/647801

Change 647645 merged by jenkins-bot:
[mediawiki/extensions/CentralAuth@REL1_35] composer.json: Remove php requirement

https://gerrit.wikimedia.org/r/647645