Page MenuHomePhabricator

mwgate seems to be failing all the time
Closed, DuplicatePublic

Description

From this:
https://gerrit.wikimedia.org/r/c/mediawiki/extensions/EventLogging/+/648288

10:38:18 + npm ci
10:38:34 npm ERR! cb() never called!
10:38:34 
10:38:34 npm ERR! This is an error with npm itself. Please report this error at:
10:38:34 npm ERR!     <https://npm.community>
10:38:34 
10:38:34 npm ERR! A complete log of this run can be found in:
10:38:34 npm ERR!     /cache/_logs/2020-12-14T09_38_33_997Z-debug.log
10:38:34 Build step 'Execute shell' marked build as failure

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 14 2020, 1:16 PM

From a quick Google, this might be npm cache corruption? Does this only happen on one of the agents?

Mentioned in SAL (#wikimedia-releng) [2020-12-14T19:46:26Z] <hashar> integration: deleting faulty npm cache integration-castor03 /srv/jenkins-workspace/caches/castor-mw-ext-and-skins/master/mwgate-node10-docker # T270100

I could not reproduce using:

sudo install -o nobody -g nogroup --dir cache src
docker run -v "$(pwd)/src":/src -v "$(pwd)/cache":/cache --init --rm -e ZUUL_BRANCH=master -e ZUUL_URL=https://gerrit.wikimedia.org/r -e ZUUL_PROJECT=mediawiki/extensions/EventLogging -e ZUUL_REF=refs/changes/61/647261/2 docker-registry.wikimedia.org/releng/ci-src-setup-simple:0.4.2-s1
docker run -v "$(pwd)/src":/src -v "$(pwd)/cache":/cache --init --rm docker-registry.wikimedia.org/releng/node10-test:0.6.1-s2

So that must be the cache indeed thanks @Jdforrester-WMF

hashar closed this task as Resolved.Dec 14 2020, 7:58 PM
hashar claimed this task.

Fixed ;)