Page MenuHomePhabricator

Import npm 6.14.8 to buster dist. on apt.wikimedia.org
Closed, DeclinedPublic

Description

T269762 and T269957 give some good background info, but essentially the WVUI project requires npm version 6.14 and above to use a particular CLI option (npm version --preid) that is only available on npm versions 6.x and above.

This is a request to import npm version 6.14.8 currently available in buster-backports to apt.wikimedia.org under a new npm component.

Event Timeline

jbond triaged this task as Medium priority.Dec 30 2020, 12:52 PM
jbond added subscribers: jbond, MoritzMuehlenhoff.

@jbond - do you have a rough estimate on when this task will be completed? We're planning for the deployment of WVUI and wanted to sketch out the timeline.

@ovasileva sorry for the delay i had meant to catch up with @MoritzMuehlenhoff but got missed during the holidays. will follow up and provide a more concrete update tomorrow.

@ovasileva in case you missed it i added comment on T269957

@ovasileva in case you missed it i added comment on T269957

@jbond - Thank you!

Closing, as discussion on T269957 has moved back to using buster backports instead.