Page MenuHomePhabricator

Reproducible Internal Error: Null thread passed to linkInContextData
Closed, ResolvedPublic

Description

Go to https://secure.wikimedia.org/wikimedia/liquidthreads-labs/w/index.php?title=Thread:Talk:LiquidThreads_testing/Abstimmungs-Test_1&lqt_method=thread_history & click "20:19, 3 September 2010"

You get:
Null thread passed to linkInContextData
Backtrace:
#0 /usr/local/apache/common-local/wmf-deployment/extensions/LiquidThreads_alpha/classes/View.php(155): LqtView::linkInContextData(false, 'page')
#1 /usr/local/apache/common-local/wmf-deployment/extensions/LiquidThreads_alpha/pages/ThreadHistoricalRevisionView.php(76): LqtView::linkInContextURL(false)
#2 /usr/local/apache/common-local/wmf-deployment/extensions/LiquidThreads_alpha/pages/ThreadHistoricalRevisionView.php(62): ThreadHistoricalRevisionView->getChangeDescription()
#3 /usr/local/apache/common-local/wmf-deployment/extensions/LiquidThreads_alpha/pages/ThreadHistoricalRevisionView.php(122): ThreadHistoricalRevisionView->showHistoryInfo()
#4 /usr/local/apache/common-local/wmf-deployment/extensions/LiquidThreads_alpha/classes/Dispatch.php(85): ThreadHistoricalRevisionView->show()
#5 /usr/local/apache/common-local/wmf-deployment/extensions/LiquidThreads_alpha/classes/Dispatch.php(184): LqtDispatch::threadPermalinkMain(Object(OutputPage), Object(Article), Object(Title), Object(StubUser), Object(WebRequest))
#6 [internal function]: LqtDispatch::tryPage(Object(OutputPage), Object(Article), Object(Title), Object(StubUser), Object(WebRequest), Object(MediaWiki))
#7 /usr/local/apache/common-local/wmf-deployment/includes/Hooks.php(133): call_user_func_array(Array, Array)
#8 /usr/local/apache/common-local/wmf-deployment/includes/Wiki.php(469): wfRunHooks('MediaWikiPerfor...', Array)
#9 /usr/local/apache/common-local/wmf-deployment/includes/Wiki.php(70): MediaWiki->performAction(Object(OutputPage), Object(Article), Object(Title), Object(User), Object(WebRequest))
#10 /usr/local/apache/common-local/wmf-deployment/index.php(117): MediaWiki->performRequestForTitle(Object(Title), Object(Article), Object(OutputPage), Object(User), Object(WebRequest))
#11 /usr/local/apache/common-local/live-1.5/index.php(3): require('/usr/local/apac...')
#12 {main}


Version: unspecified
Severity: major
URL: https://translatewiki.net/wiki/Thread:Project:Translator/_de_Deutsch_%E2%80%93_Deutsch_%282%29?lqt_oldid=587

Details

Reference
bz25038

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:11 PM
bzimport set Reference to bz25038.
bzimport added a subscriber: Unknown Object (MLST).
DieBuche created this task.Sep 3 2010, 10:56 PM

Or choose either "19:56, 3 September 2010" or "20:18, 3 September 2010".

Also [[|Reply]] is not valid wiki syntax

This one goes to Adam.

Can this bug be closed? The liquidthreads-lab wiki isn't around any more, afaict.

Indeed, and I can't seem to reproduce that bug on other LQT installs anymore

2013-03-11 05:42:35 v22011026445052.yourvserver.net mediawiki-bw_: [3fee5ef8] /wiki/Thread:Project:Translator/_de_Deutsch_%E2%80%93_Deutsch_(2)?lqt_oldid=587 Exception from line 142 of /www/translatewiki.net/w/extensions/LiquidThreads/classes/View.php: Null thread passed to linkInContextData

Nemo: Is there a specific URL to see this problem on twn?

(In reply to comment #6)

Nemo: Is there a specific URL to see this problem on twn?

The URL mentioned in the error. :D
Moving to URL field.

sumanah wrote:

Asking Krenair to take a look since this is a blocker currently affecting translatewiki.net. Removing Adam Miller (email is no longer going to Adam anyway).

(In reply to comment #1)

Also [[|Reply]] is not valid wiki syntax

Related to bug 28138 comment 6? Probably another bug.

Still current, but I don't see what this is blocking.

Jorm removed a subscriber: Jorm.Dec 26 2015, 7:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 26 2015, 7:29 PM
Jdforrester-WMF lowered the priority of this task from Normal to Lowest.Aug 4 2016, 11:35 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

LiquidThreads has been replaced by StructuredDiscussions on all Wikimedia production wikis (except one, which will be done soon). It is no longer under active development or maintenance, so I'm re-classifying all open LQT tasks as "Lowest" priority.

Nemo_bis raised the priority of this task from Lowest to Normal.Aug 5 2016, 7:31 AM

Change 383116 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/LiquidThreads@master] Work around "Null thread passed to linkInContextData"

https://gerrit.wikimedia.org/r/383116

Change 383116 merged by jenkins-bot:
[mediawiki/extensions/LiquidThreads@master] Work around "Null thread passed to linkInContextData"

https://gerrit.wikimedia.org/r/383116

Krinkle closed this task as Resolved.Oct 27 2018, 8:20 PM
Krinkle assigned this task to Nikerabbit.